Quick Start section in Tutorial

The Change List for the new v 1.9 for Windows says a new Quick Start section has been added to the tutorial. I don’t see it.

If you already had created a tutorial project and updated to 1.9 without uninstalling the previous version, the “Interactive Tutorial” link is going to point to the existing project. Delete or rename that project so you’re prompted to create a new tutorial when you choose the menu option.

Jennifer -

Okay - did that. Still don’t see any Quick ref…

The Quick Start is a collection–do you see that, if you open the collection tabs with View > Collections > Collections or the Collections toolbar button? Toward the bottom of the Start Here document, do you see mention of the Quick Start collection?

No and no. It seems I am still working with an old tutorial, even though I have deleted the tutorial folder and tried again, several times.

Just giving this a bump. It must be something simple I’m doing wrong.

Try doing a windows search using the file browser. Take careful note of the tutorial project’s name in the title bar of the Scrivener window.

Then, using the windows file browser, search for that name, adding a ‘.scrivx’ to the end.
Right click on the result (assuming you got it), and choose “Open file location”.
You should see the full path to the folder containing the .scriv project in the area near the top of the file browser window (looks very similar to the web address/URL bar in a web browser).
Close Scrivener.
Navigate back to the enclosing folder of the .scriv folder and delete it.

Robert -

Thanks for the reply, but I know exactly where I’ve saved the tutorial and I’ve been deleting it over and over without success. I even just tried uninstalling and reinstalling the program, and THAT didn’t work. I’m stumped.

This is kind of embarrassing, but I’ve just noticed that I also cannot see the collection in my newly created v1.9 tutorial. I’m pretty sure I’ve got the newest possible one, as the document “START HERE” contains a heading called “Getting Started Quickly” which says “The most important sections have been gathered together into a ‘Quick Start’ collection.” But when I click the collections button in the toolbar, the only tabs I see are “Binder” and “Search Results”.

I can’t believe I didn’t check for myself that it was there, but at least we’re in this together, MajorMajor!

Is anyone able to see the Quick Start collection in the Windows 1.9 tutorial? If you can, did you run the beta version (I did not)?

Nope, I can’t see it either. I did not run the beta version.

I’m going to call that a bug then. I’ve posted in the Bug Hunt (Windows) forum… viewtopic.php?f=32&t=32584

Interestingly, in an email conversation with Tech Support, the fellow had me find and copy the tutorial folder fro the Scrivener program location to another spot on my hard drive, and I then able to double-click the turorial.scrivx file and it opened correctly in the program. Is it possible something is broken about where the new version looks for its own tutorial?

Bump.

Interestingly, after installing v. 1.9, I find within C:\Program Files (x86)\Scrivener a Tutorial.scriv folder, and within that, two .scrivx files, one named project and the other Tutorial. That’s really unexpected. If I open the project called project, its collections include one labeled Quick Start; same for the one called Tutorial. This doesn’t help, I don’t imagine, but I thought it odd.

Sorry for the delay on this; we’ve been running short-staffed I’ve gotten behind on the forum. Thanks for your patience.

My best guess with this is that the auto-update did not properly replace the existing Tutorial project but rather merged them, which is giving some odd results. The Tutorial.scriv packaged in the 1.9 installer contains the updated files, the collection, the whole shebang, and most people aren’t experiencing this problem (phew). I’m getting confused though with the specifics of what’s on the computers and in the tutorials of those of you with this problem, however, so please humor me as I try to get this sorted:

  1. If you create a new tutorial project via Scrivener’s menu after a full uninstall–deleting the installation folder (e.g. C:\Program Files (x86)\Scrivener) if it remains after the uninstall–and reinstall of 1.9, is the tutorial still the old version, e.g. there is no mention of the Quick Start and no Quick Start collection?

  2. If the tutorial created above is an old version, go into the installation directory and manually copy the Tutorial.scriv folder there, then take a look at the copy. It should have only a “Tutorial.scrivx” project file inside, not two .scrivx files. Does that look right?

  3. If you open the copied Tutorial.scriv, does it have the Quick Start mention toward the bottom of the “Start Here” document and the Quick Start collection in the binder?

For those of you who haven’t gotten this working at all, I’ve attached a zipped copy of the tutorial project packaged with 1.9. [EDIT: I fixed an unrelated mistake and re-uploaded the tutorial here for anyone who needs it.] If you download and unzip it, you should be able to open it and work through the tutorial properly, with the collection, etc. You can also try replacing the “Tutorial.scriv” inside your Scrivener installation directory with this version, which may resolve the problem if it’s down to an auto-update issue corrupting the built-in project.

This isn’t enough of a problem for me to do an uninstall and reinstall. I did do some checking of “file modified” dates. In C:\Program Files (x86)\Scrivener\Tutorial.scriv, project.scrivx is dated 3/10/2015; Tutorial.scrivx is dated yesterday, which is probably because I opened and closed it yesterday, seeking and finding the Quick Start Collection, which it does have. If I examine Files\Docs in that .scriv folder, the file dates range from March 2011 to October 4, 2015. Tutorial.scrivx and project.scrivx seem to open the exact same project.

I find that I also have a Tutorial.scriv folder in the Scrivener folder in My Documents. It is one that I clearly used (and modified) when I first began using Scrivener. I probably moved it to that folder myself.

If I completely uninstall Scrivener, using the uninstall program and the delete the Scrivener folder, then reinstall, then a newly created interactive tutorial project does have the Quick Start collection. :smiley:

What I did before was to download 1.9 and install it in the same folder as the old Scrivener installation. Since the updater was insisting that I had to log on as an administrator (which I can’t; I don’t have that account/password on this computer), I had to bypass it and install from scratch. But now I know that I have to uninstall and wipe out the install directory first before taking this approach to updating.

MM -

NONE of these solutions worked for me, including the new tutorial you attached. The only version that works for me is the one that Jeff emailed to me in private correspondence. When I replaced the tutorial.scriv folder in the installation directory with THAT one, it finally worked. Hallelujah.

Thanks for the clarifications!

Scrivener should be using the “Tutorial.scrivx” file in both cases, since they’re both present in the project. When there are multiple .scrivx files, Scrivener 1.9 uses the one with the name matching the .scriv folder. If that does not exist, it uses the one called “project”. If that also does not exist, then it uses the most recently modified. The other files are not affected, so you can manually examine them in an XML editor for comparison if needed to resolve conflicts. Normally of course you’ll only ever have one .scrivx file in a project, so having multiple indicates usually some sort of sync conflict–e.g. the project wasn’t fully synced via Dropbox before being opened on another computer–and you may need to do a little work to clean it up afterward.

Phew! I’ll check into what’s up with the overwrite process you used first; it presumably followed the typical Windows behaviour of merging the Tutorial.scriv folders rather than overwriting it entirely (i.e. it only updated files that had been modified, and since the old version had a “project.scrivx” and the new one had a “Tutorial.scrivx”, the older one wasn’t replaced with the newer).

Well, I am stumped. Multiple installations of Scrivener (or traces of an old installation that wasn’t fully removed) might cause this, if the wrong version was being opened, but there’d have to be a lot of wires crossed somehow. I’m relieved you were able to get it all sorted with the tutorial project you got from support.

Verrry interesting. So I renamed project.scrivx and clicked on Tutorial.scrivx, which opened the project as before, with the Quick Start collection. Then I renamed Tutorial.scrivx and clicked on project.scrivx, which (a) caused project.scrivx to be renamed Tutorial.scrivx, as expected; and (b) opened a project without the Quick Start collection: the Collections tab only shows Search Results, - Binder -, and Binder (but there is a section titled Getting Started Quickly on the first page, which does reference the Quick Start collection). What other differences there may be between the two I haven’t time to investigate, since I don’t really need the Tutorial just now. Sounds like I should just delete project.scrivx and move on. Hope this is in some way helpful.