Quick zoom shortcuts in korean input mode doesn't work

In english input mode, ‘z’ is for quick zoom shortcuts. But in korean input mode, ‘z’ doesn’t work.

Please make all shortcuts work weather using english or other language input.

1 Like

I’ve never heard of a quick zoom feature in Scrivener, and the manual doesn’t mention it. The only shortcuts associated with zoom levels are ⌘> to zoom in and ⌘< to zoom out. Are you talking about a Windows feature, not a Scrivener feature? How is z a shortcut, if you need it to type words like zoom?

Anyway, if Korean characters don’t include z, what character would you want to use instead?

Ahem… this is the Scapple forum. :smile:

As for the problem:

  • @sleepyblue doesn’t tell us Windows or Mac

  • I presume Korean, like Chinese and Japanese is a two-byte language, and with a CJK keyboard pressing the ‘z’ itself wouldn’t input the requisite code-point to the interface.

  • On the Mac—at least when using Chinese, and as this seemed to be the answer for the poster who was having trouble entering our ‘arabic’ numbers with his keyboard inputting the Arabic language, I presume it’s universal for non-Roman keyboards—the answer might be to engage caps lock when wanting to write Roman script, though it must be set in System Preferences → Keyboard → Input Sources.

So, @sleepyblue, see if that works in Scapple to use ‘z’ for the zoom shortcut.


What is that even supposed to do?

Yeah, I’m always forgetting to notice what forum I’m in. Oops! If I had this problem, maybe it would be possible to choose a Korean character trigger for a macro in Keyboard Maestro, Better Touch Tool, or equivalent.

I can only speak for Chinese and the PinYin romanisation input system. CJK characters require two bytes and use a totally different range of code points. So if you just press the ‘z’ key, it doesn’t send U+007A (the unicode for ‘z’), it waits to see what your next key presses are to work out which ‘letters’ fit what you input; ‘z’ can be followed by ‘a’, ‘e’, ‘h’, ‘i’ or ‘o’ or ‘u’, and then with other ‘letters’… The first character of the word for “China” is 中 for which you type ‘zhong’ and you are then presented with all the characters and common combinations of characters that have or start with that pronunciation. It tries to predict as you are typing, so typing ‘z’ immediately brings up a panel showing

The Roman letter ‘z’ is not there. So, if I am using Scapple and have my keyboard switched to PinYin entry, tapping ‘z’ won’t zoom the board.

While typing PinYin, if you want to enter Roman letters, i.e. if you want it to enter ‘z’ you use the Caps Lock to switch to Roman, though that must be set in System Preferences as I said above. Personally, I switch back to my British English Input System because the Roman glyphs in the Chinese fonts are badly drawn and kerned.

All that said, I presume the same problem occurs with Korean and Japanese—and probably Arabic, Hebrew, Cyrillic and all other non-Roman scripts. Hence my suggestion to the OP, though whether it will work, I don’t know.



Thank you for all the reply. I’m using mac by the way.

Yes, korean character is using 2 byte input system. I use caps lock for hyper key by using karbiner and right option key to change input method. As far as I can tell, it wouldn’t work, press z with caps lock. Yes I can change input method and press z for zoom and change input method again, but it makes real headache.

Other shortcuts have no problem, since it is combined shortcuts with shift, command, etc. Other apps like finalcut pro or davinci resolve has same issue. So, I think if scapple provide another shortcut for quick zoom feature, it would be help. And it should be combination of shift, control, option or command.

Just to make sure I get it (guess I don’t)… Are we talking about any of those zoom commands?

Oh, there is a secret zoom hot key. When you press and hold ‘Z’, it instantly zoom out all the way, then unhold zoom in again where your cursor is. It’s really usefull.

Wow, you’re right. I had no idea this even exists. :face_with_raised_eyebrow: Weird. Now I understand.

Not even works. You can type “z” this way, but Scapple ignores it. Why was it implemented like that?

Pity it doesn’t work for you! I’ve just tried making the window on one of my boards very small, setting the input system to PinYin and then pressing the ‘z’ key. Very surprised that it does work for me, but then PinYin uses Roman characters, whereas your Korean input system doesn’t I believe. Also, my system is British English, so if yours is Korean that may be at the root of it.

Sadly there is no “Quick Zoom” menu entry, meaning you can’t create your own shortcut, so I can’t think of any solution other than changing input systems. For me the switch is Ctrl-Space which I don’t find at all irritating to use on the fly.


Thanks for letting us know about this problem. I’ve put it on our list to put some thought to. Out of curiosity, do you use any graphic design programs, such as Photoshop, Affinity Photo or similar? It is very common for such tools to use single key shortcuts, like “S” to use the Selection tool. How do these programs handle this problem?

@xiamenese: Sadly there is no “Quick Zoom” menu entry, meaning you can’t create your own shortcut, so I can’t think of any solution other than changing input systems.

Yes, mainly because it would result in a menu command that doesn’t do anything if you tried to use it. So while adding it would certainly be one way of solving it, I think it would only result in larger widespread confusion.

I’m only using davinci resolve and final cut pro x. and they have same problem. But it’s not a big deal, because not using korean that much on that program. And also final cut pro has second shot cut mapping that can solve this problem.

Well that’s the part that I am curious about. How do these programs handle this problem? What kind of shortcuts do they use?

I don’t know about davinci resolve, but in final cut pro, it can import custom shortcuts. Some user made that custom shortcuts and released. It’s the key basically the same position of enlish letter in korean letter. On korean keyboard, ‘z’ and ‘ㅋ’ are on same keycap, so on korean input mode, just press ‘ㅋ’ and that does same function when you press ‘z’ in english mode.



You can see bottom of image, there is alt + c and also alt + ㅊ.

Okay perfect, thanks! That’s what I was wondering, if just the key press itself is good enough.