Random blank pages in PDF compile


I’m compiling a book to PDF for print, but I am discovering some random blank pages.

With “show invisibles” on, I do not see anything different on the pages before these blank pages. Any idea what to look for? Thanks1

Is your project just a long list of documents on the same level? No folders or subfolders? One possibility is that you have chosen a section layout in Compile that says that all Binder documents should start on a new page. An extra return at the end of a document may then happen to end up on a new page, and the Compile format then make a page break to start the next document on a new page.

Ah – I took away the last pilcrow and that fixed it! Don’t know how I missed that. Thanks!

For future reference, there’s an option in the compile settings (under the gear icon tab in the rightmost pane) to “Remove trailing whitespace from documents” that will help clean up this sort of issue automatically during the compile process–it won’t fix it within your project, just in the output, but it’s a handy tidying tool.


1 Like

I figured it out. Thank you very much.

I do not see the gear in the right most pane

The blank pages have come back

I keep getting random blank pages again. I selected the gear for removing white pages and it used to work but now it doesn’t. I was told that I could go to invisible mode but I don’t know what to do with that. No direction. I saw paragraph marks below my writing and deleted those but still getting blank pages. I’ve noticed there are paragraphs symbols after a paragraph which seems normal. I only have blank pages three times between three chapters. I need help! Submitting work tomorrow! Thank you!

How to delete random blank pages in between chapters.

Could you provide more information? What File Type are you compiling for, what Compile Format are you using? Which Scrivener-version? Which OS?

If you’re Compiling for e-book, for example, remove whitepace at the bottom of your pages…

1 Like

It is a MS word document. OS 14.4.1 (23E224). It is not an e-book.

In that case, I would check the settings in the Separators pane of the Compile Format Designer very carefully, perhaps reread the Scrivener Manual to make sure you master the settings meaning.

The Compile Format Designer is reached by double-clicking the Compile Format you’re using in the left column of the Compile Overview window.

I need step by step help. I don’t know what to select under separator. I have selected remove white pages, and was told to look at invisible mode but I have no direction on how to use it. Any help would be greatly appreciated! Thank you.

It may be easier to assist if you show us the different Section Layouts components you’re using.
I use a different naming convention for my layouts that’s clear to me, but what do each of your components in Compile Format Designer > Separators > Section Layouts look like in terms of Use default separators, Separator before sections, Override separator after, Blank line separator, and Ignore blank lines using styles?

It’s best to paste a picture for each component, similar to the one below.


I have noticed there is a bug at least with the “start section on” settings for layouting. It goes off-index if you use inline page break anywhere in your text. This causes page breaks to appear even middle of section text as the inline break activates the “start section on” even though it’s technically still middle of rendering current section. Problem is fixed if you split text into multiple documents (and adjust the layout for different documents) and never use inline page break. Maybe you have inline page break somewhere?