RC 13 install fails

Attempting to install RC13 via the Help menu, downloads the update. After download, clicking on update results in Scrivener closing and nothing happens. Task Manager reports no running apps.

Win 10 Pro.

Restart of Win no effect.

Occasionally the following dialog appears

Update, bit the bullet and uninstalled RC12 and fresh install worked.

Neither the internal update nor uninstalling RC12 and reinstalling RC13 worked for me (get to splash screen, and program just hangs, using 30% CPU indefinitely)…uninstalled RC13, found my RC12 download, reinstalled that and works fine…

RC 13 won’t install.
Edge blocks the file from launching after download.
Chrome downloads the file but Windows security blocked it from installing.

I installed it perfectly happily in Windows 10 Home running in a VM. Downloaded with Opera (Chrome-based; I don’t use Edge); BitDefender blocked it and came up with an alert (first time ever … I had to wait an age while some Windows updates were installed and then had to keep telling it not to change various settings), so I clicked on “More” or whatever it was and chose “Install anyway”. Job done.

I also installed it under CrossOver (WINE) with no problems at all.

So I guess it’s your various virus-blockers getting in the way.



Here’s how to get past that in Chrome, Edge, or other Chromimum browsers. I did this from Edge Chromium:

First, when you go to download the file, you’re going to get the following warning. Click the “…” button and select Keep as shown.

Next, the Downloads manager page will open up, and you’ll see this second warning. Click where it says “Show more” which will then change to “Show less” (as shown) and click “Keep anyway”

Finally, click the “Show in Folder” to open Windows Explorer to your download location. When you double-click on the downloaded installer, SmartScreen will pop up this final warning. Click “More” and you’ll have the “Run anyway” button revealed. This will mark the executable as safe and you should see no further prompts for this file on this system.

In the interests of full disclosure, should have mentioned run Win 10 under parallels on mbp. I had the Edge download issues mentioned (dog of a pgm) and downloaded in MacOS/Safari then installed under Win. Give me Mac any day :slight_smile:.

Counting the days (25) until I can order the new M1 MacBook Air/Pro (decisions!) I know, can’t (yet) run Win on it but keeping the 16” for the time being.

On the subject of Win on ARM, Keith, any intention to do a native ARM Win version?

Having read your thread—even though you hadn’t mentioned trying to instal it under Parallels on a Mac, I didn’t try to upgrade from within Scrivener.

I use Opera on my Macs, so when I got Windows running under VirtualBox back in September, the first thing I did was install it there. So I downloaded the Scriv installer using that.

I also downloaded using Mac Opera and installed it using CrossOver. Apart from the fact that CrossOver 20 won’t run the text-to-speech DLL, under CrossOver, it installed much more quickly, opens up more quickly and runs just as well with better integration with the Mac folder system.



Sorry guess I should’ve started a separate thread, but thought I was being ‘helpful’ by posting another installation issue, but mine had nothing to do with Windows SmartScreen, which I got around easily. To be more precise about my own issue

  1. The internal updater would not work at all (for the first time–it is what I have always used till now
  2. A manual download of the x64 installer did install, but upon trying to start the program it just hung at the splashscreen and then nothing (except for a never-ending 30% CPU-load

I have no problem with RC12, except a slight worry that it might expire before RC14 comes out :slight_smile:

I tried to install b14 this morning, both via the internal update and by downloading it separately (x64), and the above error repeated itself. But when I downloaded the x64 non-high-DPI version, it worked well, finally. My question: is there something in my somewhat aged laptop getting in the way of the non-deprecated version? (With problems with the older version of Qt?) I just don’t want to have issues with the final release…I am running the latest version of Win 10 on this computer (20H2). Thanks

Update: the install of the non-high-DPI version went smoothly, and the program opened. But when I closed it and re-opened, it gets stuck at the splashscreen again (I can see it is loading the previous project path), again with constant 30% CPU usage, but nothing really happening after that

Just FYI: Edge is also Chrome-based. I don’t use it either, except to download Firefox the first time. I honestly tried it, but it kept getting in the way of me doing things, so I stopped, complained to Microsoft, and went back to FF and Chrome itself.

I installed the 32-bit version of RC13 in Virtual Box under Linux, no issues.