RC 13 Keeps Closing after about 30 seconds

I downloaded the newest update to Scrivener 3.0 BETA and now every time I open up the program, it goes to the project I was working on but closes in about 30 seconds. If I go to try and search for updates through the program, it closes immediately. I have rebooted my computer and tried to re-download/reinstall the newest version but it keeps having the same issue. Any suggestions on what I can do to fix this?

Does Closes after 17 seconds help?


Hello, thanks for the link. It did help in that I saw some folks using 32bit in lieu of 64 which is what I was having trouble with. I saw several notes about anti virus software closing it out as a possibility, but I can’t figure out what setting is doing this. I downloaded the 32bit version and am using it without issue so I’ll do that for now and give 64 a shot once the next update comes out. I do get a new message now from Windows Defender when I go to install 64 bit. It tries to stop me from installing the program so I can only assume it’s also closing it on me.

What happens if you follow the steps here:

Does that allow you to successfully download, install, and use the 64-bit version?

I’m not sure it’s going to be welcome to mention this, but don’t these problems seem to occur only when using Microsoft’s built-in ‘virus’ protection, with no normal (as most persons use) paid third-party protection substituting for it?

I mention this for two reasons.

  1. I use Norton 360, as Norton has been for the past ten years truly excellent in protection, and has none of the problems that existed for an earlier period. It’s transparent, has no noticeable effect on performance, and regularly receives top ratings in protection. You can get - and renew – it inexpensively through Amazon.

  2. For work in an EU grant program, I recently looked into how Microsoft treats download-marking certificates, the kind that software producers use to keep internet protections aware that they are safe, so that you get no messages – or shutdowns – in installing or using them.

Frankly, I found Microsoft’s approach to be nightmarish. With an ordinary certificate, you have little or no hope they will ever ‘recognize’ your program, so it will continue to set off alarms with Windows, even though ‘virus’ protective packages know it’s ok. You can of course buy a ‘super’ certificate, pay again a high price to renew it every year, and then Microsoft will agree it’s ok.

I’m not sure if you can even do that last for a program in development and constantly upgrading, as Scrivener is. However, Norton and others don’t make this problem: they accept certificates, and don’t cause issues.

— bottom line —

Annoyed as I am, I’m not sure of all the details of the above, as they are many, and I am not interested in our international/EU-sponsored project playing games with Microsoft. And I don’t know if their draconian activities here, much like some others they’ve had for years, are some new thing, thus causing new problems,

But I can say confidently that I never have trouble with downloading or installing or operating valid applications, as Scrivener certainly is, by using a normal and best security solution, which bypasses most (if not all) of Microsoft’s behavior. That includes all the betas there have been, with no funny business with browsers or anything else required.

— additional information —

  1. No, Norton, like Quicken, is no prize when it comes to their commercial operations. Thus the mention of Amazon.
  2. Once in a great while, I still get an are-you-sure interrupter from Microsoft in trying to launch a fresh app installer. I just click through the Microsoft smokescreen (try More Information…) and allow it. If I have any doubts, I do a fresh check using Norton first. After a day or a few, Microsoft catches up, and this new installer is then with them ‘ok’.

An interesting thought NARRSD, but:

  1. For me it only affects the HDPI versions of scrivener - both 64 bit and 32 bit. It has only happened with RC12 and RC 13. I’ve happily installed and used every previous version of the Windows 3 Beta.

2.I use F-Secure. But F-secure does use elements of Windows Security (I think) so that does raise a question mark.

I will try turning off all security and reinstalling the HDPi versions in case it does show up something.

For what it’s worth, I’ve also already tried upgrading my Graphics Driver in case that was an issue. Yesterday I also updated Windows 10 to the October release but no joy.

I think this may be a tricky one for the Dev team to pin down.


Good points all – and of course my suggestion may not be the problem.

Interested in what you find, though :slight_smile:

I’ve tested turning off F-Secure and that made no difference. What I’m not sure about is whether there are any underlying aspects of Windows defender running in the background.

There are probably around half a dozen main security suites people use, If one of these suites was the problem I think there would have been many more reports of this issue.

I also use Malwarebytes Premium. Turning their protection off also made no difference.

I think security might be a red herring - that’s not to rule it out completely. There may be different reasons for the closures for different people! But the Devs need to be able to replicate the problem to stand any chance.

Went to do some work yesterday in Scrivener Beta 13, ran into this problem.

Uninstalled the 64-bit version, installed the 32-bit, and now Scrivener Beta 13 stays open.

Same thing was going on with the high-res version, when I tried that back about Beta 10, sooo… Yeah. Fixed that by going back to the normal res version, 64-bit.

My supposition is that maybe something similar is going on with 13? Or, that perhaps the hi-res version got loaded up as the normal one on the download link for 13?

@takirks: Yes, in RC 13 the high/res version is the new default download. Thanks for mentioning that you have had this problem using RC 10, too.

It seems the auto-crash is related to the auto-update check on startup.
Could you please disable the automatic check for auto-update in the Options and try again. You must be quick to change the setting before the auto-update check is triggered. You have 20 seconds to change the Option. You could also disconnect from the Network, which will also disable the auto-update and give you more time to change the auto-update interval.

Let me know does it fix the crash for you, guys. It would be best to try both 32/64bit HighDPI Scrivener versions.

This topic will be followed further in this thread: https://forum.literatureandlatte.com/t/closes-after-17-seconds/93551/1