[RC 9] Error and Deleted Content from iOS

I updated to RC9 yesterday afternoon, opened my current project in case it needed to do any file updates, then closed it.

Last night, I went into Scrivener on iOS, synced, then opened the same project and added about 700 words to a new chapter. When I was done, I synced again and went to bed.

Just now, I wanted to write some more, so opened the project in RC9 and received the attached error. My shiny new words that started chapter 12? Gone. Wut?

Open in iOS, words also now gone. After a somewhat laborious process, I managed to recover my valid iOS file, confirmed my words were there, copied them to Google Docs, made a back up of the Scrivener files, then opened again in RC9.

Same error, words are gone. Sync in iOS, words also now are gone. At least now I haven’t fully lost them, but it is concerning. I’ve been going back and forth with this Scrivener project between Windows and iOS with no problems until now.

The actual file that I wrote the new words in was created on the Windows side when I last wrote in the project last Saturday, so it isn’t even an issue with it not liking a new file from iOS. I also confirmed I’m running the latest iOS version.

I came in on Windows 3 Scrivener with RC8 after having multiple author friends convince me it was stable at this point and safe to use. However, while 1 has many flaws, it has never errored out and just flat out deleted my words before.

For debugging purposes: All words written are in English and the files just have numbers for their titles/names. My iPad is an Air 2 running iOS 13.6.1. My PC is running Windows 7 SP1 with all available non-Windows 10 spamware updates.

I was actually able to repeat this error just now, fortunately with test data since I didn’t want to risk losing words if it was an on-going issue. Steps I followed:

Opened the Scrivener File in RC9. Put back in the words I’d lost in the file named 12. All good. Created a new file named 13 with no words. Closed Scrivener and let Dropbox Sync.

Opened in iOS. 12 is all good, 13 is there as well. So I wrote “test test” in file 13.

Closed, let it sync. Open in RC9 again. Same error, different UUID, and 13’s words are gone.

Two More Tests
After the now empty 13 version synched, I opened it again in iOS. Left 13 alone and just added a couple of words to 12. Synch. Wait a bit. Open in RC9. Test words in 12 are still there.

One more round of synching. Opened in iOS again, added a new file in iOS, put in some test words. Opened in RC9. Opened fine with no error and all words still there.

Did you let your PC:s Dropbox app sync from the server before opening in Scrivener?
Syncing on the PC is done by the Dropbox app. Scrivener has no knowledge of any syncing so it’s not a Scrivener issue.

Yes, as I said multiple times in my bug report plus in my test results to replicate it.

All syncing was done and fully finished both when it happened and in my repeated tests to replicate the step. And yes Scrivener IS aware of syncing. On iOS it always prompts if something has changed, and the PC version specifically has a setting to put synched documents a collection.

Scrivener threw the error, Scrivener deleted the content.

So yes, it is a Scrivener issue and your immediate presumption that it is not even remotely helpful. From your profile, you don’t even use Scrivener for PC, so not sure why are you popping into Beta bug reports to tell people they must have done something wrong?

… because Win Scrivener doesn’t sync anything, no more than Mac Scrivener does. When an iOS decice syncs it makes a list of which documents that has changed and Mac/PC Scrivener then reads that list and presents it as a Collection. But it is the Dropbox app that manages all syncing on your PC, not Scrivener. Scrivener assumes that all files in the project resides on your HD.

You’re not using the Smart Sync feature on your Dropbox account, are you?

Hi AnmaNatsu,

Based on the error message you’re seeing, it’s possible that RC9 introduced some incompatibility between iOS Scriv and the Win beta. I tried but was unable to replicate it myself by doing a few round trip syncs, but that’s not terribly surprising as there are so many variables in play.

Here are some questions for you that might help the devs figure this out.

You mentioned recovering your missing words after a laborious process, from the iOS side. Where did you find them?

What font are you using in IOS Scriv and in Win Scriv? Asking because in the past I’ve seen font incompatibilities cause issues between iOS and Windows.

Are you using styles or comments at all in the problem file? Asking because these things are mentioned in the error message.

Something for you to try: I experienced a similar scenario many betas ago where it looked like I’d lost words. It turned out the words were in fact in the docs, but Scriv couldn’t display them. I confirmed this by looking at the underlying .rtf files where Scriv actually stores the text. So if you do receive the error again and find yourself missing words, it would be worthwhile checking whether the actual .rtf file contains the words, even though you don’t see them in Scriv. You would do this using Windows Explorer to navigate to your Data folder, which would be within YourProjectName.scriv > Files > Data. The .rtf file in question will probably be one of the more recent ones modified. Or possibly you could use the UUID in the error message to determine which one it is. Open the .rtf n Word or whatever app you have that opens .rtf and see if your words are in there. Don’t modify the .rtf outside of Scrivener! That could cause bad things. :slight_smile:


Thank you :slight_smile:

Sorry if that part wasn’t clear, I recovered them from the Windows side. Since I have windows history turned on, I was able to delete the Scrivener folder with the missing words then restore the version before I wrote the words via Windows history . Then downloaded the rest of the restore from Backblaze to get the actual changed files and get it back to the state of it having words. It took me two rounds because after the first round, I realized for it to “stick” I had to first delete the project from the iOS Scrivener, then from Dropbox, and then do the restore. :slight_smile:

I’m using Open Sans for the font in Windows. The iOS app is using the default of Helvetica. I am using styles, it was one of the features of Scrivener 3 I was most excited about. So I have the normal style set to my preferences, then applied to all my text. iOS doesn’t obey it fully since it doesn’t appear to have Open Sans installed, but I just fix that when I sync, and then it’s fine. No comments in it though.

I just tried this and got the same error. A folder with the UUID indicated was not there at all. I also did some more tests to try to narrow things down.

I added 2 other files at the same time on the PC, one with a label, one without, in case that was part of the issue. I also put text in each of those. Both of those came over fine, as did one I created on iOS with test text.

It was only the one file that was created on the PC, with no text, that I added text to in iOS that gave an error then vanished from the Scrivener folder. I checked all the other files, just to be sure, and the one I’d added text that errored was completely gone.

Your question prompted me to try one more test.

I again added two files in the PC version, one with some text, one without. A folder for the one with the text appeared in Data, but there was not one for the one without text.

Synched, open in iOS, added text to the one that didn’t have any. A new folder for that file was then added to the Mobile > Data folder. I opened the file with text from the PC and the one that came over from mobile in Notepad ++ to see the underlying content.

File created on PC with text added:

{\fonttbl{\f0\fnil\fcharset0\fprq2 OpenSans;}}
\pard\plain \tx0\tx480\tx960\tx1440\tx1920\tx2400\tx2880\tx3840\tx4800\tx5760\fi480\sl312\slmult1\ltrch\loch {\f0\fs28 <$Scr_Ps::0>I have text, wee<!$Scr_Ps::0>}}

File created on PC with no text that had text added on iOS

\cocoatextscaling0\cocoaplatform1{\fonttbl\f0\fswiss\fcharset0 Helvetica;}

\f0\fs28 \cf0 Now lets add some text}

Then opened in PC, got the same error (as expected) and the mobile data folder was gone.

Could you please upload your iOS project before syncing it under Scrivener for Windows. This will help us reproduce the error locally. Thanks!

Thanks. I’ve attached it - the file titled 13 is the one that gets blanked as soon as I open it in RC9
ScrivBeforeSync.zip (293 KB)

Error-wise, this sounds like it’s related to the error I’ve mentioned: [url]https://forum.literatureandlatte.com/t/win3-beta-ios-version-error/47878/1]. I haven’t checked if this happens in RC 9 yet, but it did in RC 5, at least. It doesn’t seem to be a common issue, though.

Actually, not related, but exactly the same. I re-read the posts again, and realized that what I’m doing/seeing is the same thing: Create a blank doc on Windows. Edit in iOS. Return to Windows, and that document is blank.

I was noting that the text was found in one of the backup folders from iOS (I forget which, and don’t have access to that right now) and could be opened/copied from another editor and then pasted in. The UUID was the filename, I believe, and that’s how I found it.


Yep, looks like it’s the same issue. I also went back to RC8 before it expired and it happened there too. Hopefully, they can get it sorted out, since losing words is never fun.

New RC up, no mention of this bug and it still says there are no known bugs that cause data loss even though this clearly does. :-/ Average users would have lost their words, period. They would not have had the resources to recover them, and I only got lucky based on timing and having written before bed.

Until the developers can reproduce the issue, my understanding is that it doesn’t get entered into the bug database and therefore assigned a tracking number. Unless they can make it happen on their systems or clearly see evidence of a bug from the project file, they can’t start precisely defining the scope of the bug or figure out exactly what’s going wrong and what it affects.

There have been reported “bugs” in the past (especially around syncing) that turned out to be because of user error, some weird issue with the Dropbox account, or other factors that were outside of Scrivener’s control and code. They’re not taking your report lightly – one of the devs was the person who asked for your project file back in August – but it looks to me like they still can’t reproduce the bug locally.

While I recognize that the devs are not the ones who keep answering bug threads with “nope, it’s all your fault, Scrivener is perfect” type responses or claiming that anything sync related is automatically due to user error/stupidity, the fact that they also allow those responses and do not counteract them is, frankly, off-putting. And honestly, I had no idea the one person saying to upload the example was even a dev, nothing in their user name or the view I see here in the forums does anything to differentiate them from the other users? I did it since it made sense to me from a debugging perspective and was a request I’d have made myself from my users.

Putting that aside, this issue has clearly occurred for more than one user, and it is an issue with Scrivener 3 for Windows. I can consistently repeat it and spent the time to narrow it down to the exact steps required to have it happen. If they could not replicate it purely with my data file or by laying out the steps I indicated consistently reproduces the behavior, I would have expected some follow up. Yet no one replied to Rithe’s thread at all from 4 (now 5) versions ago, though I do see another fellow user was able to follow Rithe’s steps and also get the same results. And only the one response here.

Whether they call it a bug or not, the fact is they are telling people that they are: “aware of…zero bugs that cause data loss”. Emphasis on aware, not confirmed, not fully replicable, but aware of. Except that is not true, they have had bug reports, at least two at this point on this issue (and possibly more, it never occurred to me to have to hunt through the entire forum for this issue as I’d have thought it would have been on the bug list long ago).

And, with ALL of that said, I did another test today, wondering if the issue was limited to projects that had been converted from Scrivener 1 and it was not. Exact steps:

  • Created a new brand new project in Scrivener 3 Beta using the Blank template
  • Added a new blank text file (in addition to that was auto-created upon creation of the project)
  • Changed absolutely nothing else
  • Closed the project
  • Waited until Dropbox finished syncing
  • Opened Scrivener iOS - it correctly noticed changes and prompted to sync with Dropbox and of course I did so
  • Opened the test project - both blank text files were there
  • Added some words to each, two sentences or so
  • Exited the project, at which point Scrivener iOS auto-synced with Dropbox as it should
  • Waited for my desktop Dropbox to sync
  • Double checked the Mobile/Data folder was now in the project, then confirmed that both RTFS were there and had my test sentences in them
  • Opened in Scrivener 3 Beta and yep, get the same error, both text files are now empty, there are no RTF files in the main files/docs folder, and the Mobile/Data has been deleted. Since Scrivener for Windows hard deletes the mobile files after syncing, even on error, they aren’t in the recycling/trash bin, so had they been words of actual importance, they would have been lost to the void


I then wrote one letter in one file, then deleted it. At that point, Scrivener 3 Beta created folders under data for those files (they were not there from the first creation).


Did the same steps above for opening and editing in Scrivener iOS. After dropbox sync’d, I…

  • Confirmed again the mobile data files were there and the IDs matched.
  • Opened it in Scrivener 3
  • Text now kept for both files
  • Add another empty text file, then close
  • Confirmed earlier remark: it did NOT create a matching folder in Data - this SEEMS to be the hang-up
  • Did the iOS side again… but once everything is sync’d BEFORE opening in Scrivener 3, I make an empty folder in Files/Data matching the ID of the file Mobile/Data
  • Open the Scrivener file, it does its thing, and NOW the text from iOS is kept

What happens if you open the project in Scrivener and select File, Sync, with mobile devices?

Probably the same thing that just happened to me – it says there is no mobile data.

I walked through your repro steps and they are solid – I was able to confirm the exact same issue. I think you’re right in that Scrivener beta isn’t created the directory for a blank document, so there is nowhere to sync the content into.

I understand the frustration that you and others have had, but this is the first solid set of reproduction steps that I am aware of having been posted to the forums. Since I’m not an L&L employee I have no idea what has been sent privately.

We managed to reproduce the problem and doing our best to get it fixed for the next update. Thanks!

Awesome, thank you!

Thank you for your persistence on this one!