RC14 Closes after 17 Seconds

Sorry Tiho, but for me RC14 (64 bit) is still closing after around 17 seconds as per the previous thread on this subject.

I’ve emailed you a minidump and log.

Good luck. Something tells me you’re gong to need it.


Just updated to RC14 (using the auto-update option, which ran perfectly). Scrivener has been running fine for over an hour, without problems. And I never hit this quick closing bug with any previous version. So, I suspect it must be something to do with people’s specific PC setups. Other posts have suggested an anti-virus problem; for what it’s worth, I run Norton 360,

Just posting in case it helps to track down this problem.

Whatever it was/is doing the crashing after 17 seconds, it ain’t fixed. RC14 crashes even quicker than before on my system.

64-bit crashes. 32-bit hasn’t crashed as of yet. Haven’t actually started using it, but it stays open and is still open as I type.

Whatever is going on appears to be an artifact of the 64-bit high-definition versioning, because on my system, the old high-definition version back around RC11 was doing the same thing–Crash immediately.

This is the Qt bug we were getting with RC13? Disable automatic updates, and Scrivener should work. If you can’t go into preferences and unselect check for automatic updates in 11 seconds, unplug from the network.

Confirmed that it is the update check issue. Or, at least, that the program crashes when you check for updates, and it stays running once you turn off automatic updates.

Hi there,

I never had this issue. I just upgraded to RC 14 (64 bit) and Scrivener is working fine. I checked for upgrades and, again, no crushes (fingers crossed). I am inclined to believe that this issue is probably system related. Maybe a sort of conflict with other software, possibly an anti-virus program. I am using Bitdefender, for example.

My suggestion?

Before switching off your Wi-Fi, please try canceling (for the purpose of the test) your antivirus. If it is the culprit, try to disable, within its preferences, any activity related to Scrivener. Bitdefender has an option to exclude certain programs from scrutiny.

I hope this helps.

I am running Windows 10 with the latest upgrades.

P.S. If that doesn’t work, you can always uninstall Scrivener, do a registry cleaning (CCleaner is good for that and it’s free), and re-install Scrivener.

I doubt that it’s the antivirus system–I’m using ESET, and if it were having a problem with the program, it would be in the AV logs. Which it isn’t.

Add to that, the fact that the 32-bit version runs fine, while the 64-bit version does not tells us that it’s probably not the AV, either–If it were tripping that program for 64-bit, it ought to do the same for the 32-bit version as well, no?

I see your point, Takirks. However, trying is not a bad idea. Just one more step towards finding a solution for this mystery.

Unfortunately, I’m getting the same. I did an uninstall of v13, and installed the Hi DPI version of 14. I turned off my wifi, got it running, and turned off updates. Then turned on Wifi, and told it to check for updates. Immediate crash.

It’s not the antivirus. It’s a bug in the library behind the Scrivener GUI…there’s a 4 page thread about RC13 closing after 17 seconds half a page down.

This particular bug is probably almost certainly not directly due to the AV system – although the fact that even on the 64-bit systems it only affects some systems and not others still leaves some room open for doubt until Qt fixes it.

You’d be surprised how many times I’ve heard that and yet found the exact opposite to be true.


Two totally different sets of compiled code. They are going to look very different to an AV scanner, and a false positive or mis-configured signature that trips one would almost certainly avoid the other.

To back up what devinganger is saying, it’s not the antivirus at all. It’s a bug in the Qt library, or so was discussed here: https://forum.literatureandlatte.com/t/closes-after-17-seconds/93551/1 Specifically the 64-bit Qt library.

Just confirming w/64bit RC14. Still crashes when automatic update is turned on, runs solid when auto-up turned off. Have not tried the 32-bit version.