[RC6] Not possible to customise keyboard commands for "Insert" menu??

I have only just noticed this , but i wanted to customise the keyboard shortcut for the command “Insert > Bibliography/Citations…” (Scrivener manual, 20.4: Bibliography Management, p. 408).

When I went into Options | Keyboard to find the command, I couldn’t – there is no subsection for the “Insert” menu at all, and none of the commands on it are listed (with the default “Scrivener” shortcut theme loaded). If I collapse all the options to just show the menu subheadings, it’s easier to see:

Am I missing something? (I tried loading the Ms Word shortcut theme, and that doesn’t include the Insert menu either)

Also, small suggestion, please could the customise page list the menus in the same order as they appear on the un-customised main title bar (e.g. File, Edit, Insert, View, etc.,) – that would make it easier to find the command you want to edit. Thanks.

Just bumping my own question. Please could someone try this and see if they’re having the same problem, or is it something odd on my PC. Thanks.

The Insert menu heading isn’t available for me either. You can find the command for Bibliography/Citations by typing Bibliography in the filter box. It comes up under Format/Show Citations and from there you can customize the keystrokes. Hope this helps.

If you earch for “insert” there are 6 commands you can create shortcuts for. None of them are related to the Bibliography.

Thanks for responding, but it’s the insert citation command that I wanted to customise, which doesn’t show up when you search. And thanks for confirming the bug. Sorry, @Tiho, but that’s one more for the list!

Thanks for responding, but it’s the insert citation command that I wanted to customise, which doesn’t show up when you search.[/quote

When I searched for Bibliography and found the command ‘Bibliography/Citations’ under Format/Show Citations, I assumed that, although it didn’t expressly say Insert, that it was the Insert/Bibliography/Citations command because it uses the same short cut keys, (Ctrl-G, Ctrl-O). I think this is a case of the command being available but that it is incorrectly catalogued. So, yes, a bug.


Just bumping this because the problem is still present. The “Insert” menu does not appear among the options for customising keyboard shortcuts (Options | Keyboard).

Some of the commands relating to notes (e.g. Insert footnote, Shift-F5) are listed and can be changed, but the one I want to change (Insert | Bibliography/Citations, Ctrl-G, Ctrl-O) is not listed and cannot be changed.

Start typing in the search field at the top to filter for a specific action name or description.
Bibliography/Citations shortcut can be changed. Type “cita” in the top filter field and change the shortcut.

The groups are still not reordered to match the GUI menu titles, but via filtering you can reach easily any shortcut you need and not bother searching within the groups.

Many thanks Tiho! That fixed it!