[RC8] No audio on MP3/M4A files

The audio does not play on imported MP3 or M4A files. The files import into the Binder OK, and the timer ticks over as if the file is playing, but there is no audio. This is the case both when dragging and dropping the file into the Binder, and also using the Insert > File function.

I’ve managed to replicate this. I can see the bar with the audio controls, but no audio plays, and in my case the position indicator does not move.

Make sure that the Sound Level within the Scrivener editor control line is increased. You can adjust it via the Sound icon at the main view statusbar before to the elapsed time label.

No luck there either, Tiho. Volume is all the way up in the editor control line and on my device (which I should mention is a Mac, running the beta on Crossover.) I’ve tried it with multiple audio files, both MP3 and M4A, and with the tutorial audio file “ThisIsBuzzAldrin”. Position indicator refuses to move and the hourglass cursor stays put as well.

“ThisIsBuzzAldrin” does play, but I found a couple of things with the controls that make it seem like it isn’t:

  1. The volume control indicator does not reflect the actual volume level.
    Annotation 2020-08-09 130844.png
  2. Clicking the volume control indicator shows that the volume defaults to 0 even though the indicator shows 100%. It does not change based on the volume setting.
    Annotation 2020-08-09 130949.png
  3. The media playback scrubber does eventually move at the very end of the media playback - it flashes to the end, then back to the beginning. This could be because the recording is very short.
    Annotation 2020-08-09 131050.png

I found a longer mp4 (no audio) that allowed me to check the playback scrubber - it does move, but in fits and starts (jerky), even though the movie played normally.