I created the Ready-Set-Do! program – a file-system approach to getting things done on the mac. And one of the things I love about Scrivener is it’s ability to import and export to the file system. Since I do my initial brainstorming on projects using Ready-Set-Do!, it creates all of the folders I need to keep my project organized. I then just import it to Scrivener and I already have most of my basic structure ready to go. I’m always looking for feedback and suggestions on Ready-Set-Do! and would love if others had any ideas for better RSD / Scrivener integration.


I’d love to give it a try. But: Your website says “OS X must be set to English” - I am running OS X in German. Does that mean that RSD won’t run on my system?


I’ve got RSD ready to be localized into any language people are willing to translate it into. It’s really just a matter of manually changing the comments located in the “_RSD Settings” folder. The German version should be ready within the next couple of months. Other languages are also being worked on. You can see the Translate link at the Ready-Set-Do! website for more info.

Hi Todd,

I’ve just downloaded and tried RSD, but my desktop is set to German too and some things does not work as shown in the movies. Is this due to this language thing? Then I’ll try it again, when it is localized.

(BTW: You would get more feedback, if your forum does not require a mac account. )


“Couple of months” - did you include Moby Dick or the Bible in the comments? How much text is there to be translated?


The issues that will come up for any computer with international settings set to something besides English will have to do with things like:

The name of the desktop
The name of the kind of file – e.g. folder, alias

These are different in German and other localizations of OS X. If you want to fix it so that it will work with German or another localization of OS X, you can briefly set your OS X international settings to English to install RSD with the installer. Once installed, you can change it back.

Then to get RSD to work with your language, just change some of the variables by locating the following file path:

<< your home >> --> Library --> Application Support --> Ready-Set-Do! --> _RSD Settings

Inside that folder are the settings for RSD. Locate the “GLOBAL VARIABLES” folder and find

#050 - desktop
#145 - folder
#146 - alias

Look at the comments for each of these and change them to the appropriate name in German or whatever other language you use. Once those are set, most everything should work fine; but of course the dialogs will be in English. If you’d like to change more you can anything you want to have it work to your liking and in your own language. I’m attaching the RSD Index that explains what each variable does in case you’d like to fully customize your own RSD experience.
RSD Translation Index.pdf (135 KB)

Hi Todd,

I’ve installed RSD in the way you described and it now works in most cases as expected. Only the option “Connect to project” does nothing afaics.

And it is slow on my G4-Powerbook.

I am still evaluating, whether I can use it, but the concept is really interesting.

Just change the comment for item #02 in Shortcuts located in the following file path and it should work:

<< your home >> --> Library --> Application Support --> Ready-Set-Do! --> _RSD Settings --> Shortcuts --> (check here)

Hope that helps.

Change to what? Sorry for being in the dark. :confused: