Recent Documents Menu Unpopulated

El Capitan has had several issues with the Finder. One of these is the failure to populate the Recent Documents menu. Supposedly this was fixed in the last release to El Capitan and for many programs (e.g. Rapid weaver and others) the fix has worked. Unfortunately, the Scrivener Recent Documents menu remains empty. While previously it was OK to simply point to the OS, if this has been fixed with some programs, I think this issue now merits review.

Just to clarify, it sounds like you’ve checked this, but you did verify that in the General System Preferences, the recent documents setting there is non-zero?

If so the file that OSX uses to store recent documents for Scrivener, specifically, might be jammed (perhaps the OSX update itself did this—El Capitan completely changed how it stores this information so it isn’t unlikely). Try resetting that file to fix this:

  1. From Finder, use the Go/Go to Folder… command.

  2. Copy and paste the following path into this dialogue box and click GO:
    ~/Library/Application Support/

  3. You should see bunches of “sfl” files in here, basically any software you use on a regular basis that opens files and remembers them ought to have an entry here.

I opened that file location, checked to see that there was a Scrivener file; closed the location; reopened Scrivener, and the recent files menu is now populated.

It is strange that opening a folder would reset the content of existing files therein. But it worked, thank you.

Strange indeed! I had problems with this folder as well shortly after installing 10.11, my problem was that the whole folder hierarchy didn’t exist and OS X couldn’t create it itself. Once I created the folders myself then it started working again. :slight_smile:

Did what you suggested but while there were a bunch of sfl files, none related to Scrivener. So now what do I do?

Nevermind. Tweaking General El Cap preferences did the trick!