Red and Strikethrough

A beginner’s question … I just want to format the highlighted part of this text in red and strikethrough.

But I always get this.

Thanks for your help.

Does Scrivener changing all of the sentence occur only in this project?

That is, if you open Scrivener’s Interactive Tutorial from its Help menu, save the Tutorial to your Mac, and then try using strikethrough and a specific font color just on one word, does this issue repeat in the Tutorial as well?

If the Tutorial works correctly, was this text pasted in from another program? And, if it was, did you use Edit > Paste or Edit > Paste and Match Style?

I’m on a Mac with macOS 13.2.1, and I’m able to apply both strikethrough and a new font color to a single word in a sentence.

Since the behavior I’m seeing differs from yours, it makes me suspect that the text you’re working with might have some other formatting applied that’s causing the issue. That’s can happen if the text is pasted from another location.

Testing the Tutorial could help narrow down if this is specific to your Mac, your project, or this section of text.

Ok, I tried the tutorial, but there I no longer have my style sheets … or whatever it is called. :slightly_smiling_face:

I need this


Your style is a paragraph formatting style. That’s why.
You’d need it to be a character-attributes-only style.

Apply the style to a paragraph, select a chunk of it, and then create a new style.
In the style’s config, pick character attributes.

And how do I do that? Forgive my ignorance.

The answer I edited in my previous post.

Ah, yes. That works. Thank you. Can I assign a shortcut?

1 Like

The shortcut you set (select, actually ; you choose which, but can’t modify the shortcut itself) in the style’s config.
Make sure to have selected a chunk of text that’s already of that style first.


1 Like

This also worked, thank you @Vincent_Vincent :slightly_smiling_face:

1 Like

Hi, Vincent is not 100% right as he is a Windows user and as you’ve posted in the MacOS category, I presume you’re a Mac user.

If I’m right, you can give styles any shortcut you want (provided they don’t clash with existing ones) through System Preferences/Settings → Keyboard. You don’t have to use what’s offered in the dialog.



1 Like