Relationship between No Style and default editor format

In a new document, that’s true. In an existing document, it is not.

Only because pressing enter to get a new paragraph carries over format from the previous … not because “no style” acts like a style in any way.

I’ll take “Missing the Point” for $500, Levar.

Attached are three images. 1st is the Editor, the 2nd is an as-is compile to PDF, and the 3rd is with override. The first three paragraphs (after the image) are all “no style”.

As you can see, they’re all different in the Editor, all different when compiled as-is, and the first three the same with formatting override checked (as expected?).

But here’s the kicker: in both compiles, the default format is Cherry Cream Soda … but that’s not what Compile used for the paragraphs. If that’s a bug, it’s a peculiar one.

I’d be willing to bet that if you post a sample project, there’s something awry with your settings.

On the face of it, the final document shows exactly what you’d expect: all your ‘no styles’ are being reproduced in the compilation with the same format. Is the problem that you want them all to be formatted with a different font from the default compilation font? (I can’t tell what font the final screenshot is in, sorry…)

Here’s my attempt to replicate your experience:

  1. Editor with three different formats (all ‘no style’):

  2. Compile to Modern PDF with ‘As Is’

  3. Compile to Modern PDF with unamended default Section Layout (Section Text)

  4. Compile to Modern PDF with amend Section Layout Section Text font set to Courier Prime (I don’t have the Cherry font)

This seems to work exactly as one would expect. All I did with screenshot 4 was to edit the section layout (with override ticked), click on the dummy text, cmd-t to bring up the font dialogue and choose Courier Prime), then compile. Are you doing anything differently?

I am probably not getting what’s bugging you, but did you mean your default paragraph format (in Scriv prefs or Project setting) was set to that font at the time you compiled? In which case isn’t the answer just: Default paragraph format is a setting which has no bearing on Compile.

In that case, “no style” doesn’t act as a style at all, as I have suspected all along … but I’ll put together and post a sample project to see if someone finds what I may be missing.

As I understand it, the project’s default format should have applied to “no style” paragraphs, but that didn’t happen. I’ll triple-check my settings and post a dummy project if I can’t find my mistake (if I made one).

As I understand it, the project’s default format should have applied to “no style” paragraphs, but that didn’t happen.

I don’t think this is quite right. It’s the compilation format’s default formatting which should be applied, not the project’s.

I think of it this way (this may not be technically what’s going on under the bonnet…!)

Every bit of text in a Scrivener document is either ‘no style’ or ‘styled’ (it has a named style attached).

A style allocates a certain set of formatting combinations to a selection of text and all text with the same style always has that set, and the text is ‘marked’ as belonging to that style — which is why when you change the format of a style, all the paragraphs with that style can be changed immediately.

The default ‘No style’ is not like that: when you change it in preferences, you’re laying down the default formatting for all unstyled text in future, but you’re not creating the same ongoing link between the text and that specific set of formatting.

So, when you change the default text, you can update all the unstyled text to your new format manually, but even if you don’t, all the text without styles will still be ‘no style’. In other words, ‘no style’ doesn’t mean “format it this way”, it means “this text doesn’t have any style attached”.

That’s important, because every compilation format also has its own default paragraph formatting (e.g. Palatino for ebooks vs Courier 12pt double spaced for manuscript submissions) as well as its default named Styles — and they can, and often will be, formatted differently from the ones you have in the editor.

When you compile to a specific compilation format, and you assign a section layout (not ‘As Is’, of course), Scrivener formats any ‘no style’ text as that compilation format’s default paragraph.

NB: It’s not looking at the actual formatting in your editor’s ‘no style’, it’s just asking “is there any style attached”?

That’s why all three ‘no style’ paragraphs in your example are compiled to the same ‘compilation format default formatting’. To the compiler, the only thing that matters is that these paragraphs do not have a named style attached.

If you want to change the default compilation paragraph formatting, you do it by editing the section layouts (as I did in my fourth example), but this will also pay no attention to the different ways your editor has formatted any ‘no style’ paragraphs.


1 Like

Compile formats don’t have default formats (as I’d understand the phrase).

If you mean the contents of each layout’s Formatting text box (available when Override text and notes formatting is selected), that would be many default formats (one for each layout, not one for the format).

The default setting in the Formatting box (there is a style dropdown) is no style … but the default project formatting is not applied.

Hence, no style doesn’t act like a style at all. I’m almost done with a demo project.

Have a look at the section layouts for different compile formats. Those with text will all have formatting which will be applied to a ‘no style’ text. It’s their default paragraph format and it differs between compilation formats.

That’s how you can output to a submission manuscript, an ebook, a paperback, etc, with changing your project at all.

If you’re looking in the Styles pane, it may be called ‘Body’ rather than ‘no style’. The point remains: the mapping is not between different specific editor ‘no style’ formats — they are all treated alike and are mapped to the default paragraph style for that compilation format.


What would you like to bet? Here is the sample project:
sample project

default format (cherry cream soda):


with override (format is “no style”):

I don’t think the issue is with the settings - they look similar to the ones I have.

The issue is the expectation that for the compiler there are different types of ‘no style’ paragraph - there aren’t. The compiler treats them all as one and maps them on to its default paragraph format, which is what you’re seeing.


The default format is set in global or project preferences. It’s not set in stone.

Or if it is, that still blows out of the water any notion that “no style” acts like a style.

Well, obviously it’s not set in stone: as I explained in my second post!

It’s a formatting preset, which unlike a style, does not become linked to a particular selection of text. If you change the default, existing formatting will not be updated automatically, but it will still be ‘no style’ text that will be translated to a compilation format’s default paragraph formatting.

Forgive me, but it sounds to me that you’re hung up on the idea that the editor default formatting has anything to do with a compilation default formatting. It doesn’t (unless you use As-Is): text without a style in the former is mapped to the latter, that’s all. This explains why you see what you see in your project: all the ‘no style’ text has inherited the compilation format default formatting, even though in the editor the three paragraphs looked very different.

For most purposes, for people coming from Word, for example, saying that ‘no style’ acts as a style is a shorthand way of explaining that there’s no need to have a specific style like the Normal style in Word. This explanation works well enough, but it’s not an exact technical description, so I wouldn’t get too hung up on it.

So, to go back to your original question: I think what you’re seeing is expected behaviour for Scrivener, not a bug. If you did want to compile to three different paragraphs formats in your example, then two of them will have to be allocated named styles.


Exactly what I’ve been saying, and my test project proves it.

To be more exact (I hope), people have been saying no style stands for the default format. It doesn’t. Not in the Editor and not in Compile.

What it does do is allow us to override text in Compile so long as the text is no style (which we can do for styled text by overriding the style definition).

As I said, that’s just a question of terminology and it’s not that important.

Just to be clear, do you now understand why this statement wasn’t quite true? Sorry to be picky, but it seems to go to the heart of what you’ve been posting.

As I understand it, the project’s default format should have applied to “no style” paragraphs, but that didn’t happen. I’ll triple-check my settings and post a dummy project if I can’t find my mistake (if I made one).

The project’s default formatting only applied to the ‘no style’ paragraphs at the time it was changed. It would never have applied to all three paragraphs unless you chose to do so explicitly. This has absolutely no relevance to the paragraphs’ appearance on compilation, because they were all formatted using the compilation’s default paragraph formatting.

So what you saw was not a bug, it was the intended behaviour.


Changing default formatting has no effect on no style paragraphs. None. Unless you reapply no style to them.

Or in other words, reapply the no style preset, as I’ve said a few times.

That’s true IF we override Editor formatting.

There is no compilation default formatting, only layout formats … whose defaults are supposedly no style (according to the style dropdown in the Formatting text box) … but it isn’t true. If the default in that box doesn’t conform to the Editor default (which it doesn’t), what does determine it?

I never said it was a bug. I’m saying the frequent claim that no style is in some way the default format is bogus.

That doesn’t wash either. You just need to ask what it is setting the default for. It is not setting any default for Compiled output. That’s just not what the setting is about. So nothing you say about Compiled output is really germane.

Nor does it seem you are actually confused about any of this — which makes this exchange a bit of a harangue, I’m sorry to say.

I’m out.

1 Like