Remove First Line Indent fails in PDF

I can’t get “remove first line indent" to work. I documented the relevant settings (I think) in an Evernote:

evernote.com/l/AkprJ2Fr9INE … LPlS7-aCB0

What am I missing?

When I try to replicate your settings (and the compile works as desired), the preview for the section layouts shows the first-line indent removed for the first paragraph only. Your preview doesn’t. Something to do with separators, perhaps?

I switched to separators, not Prefix for the stars, and they center on the page much better.

But it didn’t cause first line no-indent to start working.

I notice you have a page-break on the section layout, where I do not. Is that the difference? But I can’t have a page break for this purpose.

According to your screenshot, you do have a page break before Scene with Prefix (on folders only). If I’ve understood what you’re doing, I don’t think it’s necessary.

Have you tried removing it and seeing what happens?

I saw a page break on your screen shot…

…so I added one to mine in the post above. Will work either way. Removed here…

Could you share a lorem-ipsum version of the project to see if anyone can figure it out?

The documents involved are not folders, so “Page Break (folders only)” should have no effect. It’s there only because I let Separators default for those section layouts. Now I’ve changed them to eliminate that Page Break setting, and it makes no difference in the PDF for either of my two scene layouts.



We’re getting to the stage where it’s not possible to help because we don’t have all the information and you can’t give us a screenshot of every panel…

As Bridey says, the easiest way to see what’s missing is to provide a dummy project — cut a copy of your project down to the essential hierarchy plus 2 chapters, say, provide dummy text and remove all personal information. Make sure you save the compile format in the project itself, not under My Formats and post it.

There’s clearly an errant setting here somewhere and this is the quickest way to find it, or to prove it’s a bug.

Here’s a link to the scrambled project.

(Is there an easier way to scramble it, by the way, than a series of random Project Replacements?)

dropbox.com/s/k1cwwviut8ioa … 2.zip?dl=0

DELETED

Thanks.

Jimmy’s Hearing is Without Prefix.

Without Prefix is classed as a scene in Assign Section Layouts.

Scene is controlled by a style.

You can flatten the first-line indent in the style options.

You’re saying the Scene style overrides the layout’s Compile setting??

Yes, it seems that the Scene style in the Compile settings has pre-eminence.

Let’s make that obvious in the settings dialog, why not?

But thanks a ton for figuring it out for me!

It does the way you have it set up. As you can see, the style is set in the Section with Prefix format:

(Click on the Style icon (pilcrow + a) or right click in the dummy text box to see the menu.)

Here’s my explanation of what’s going on and why you’ve run into this:

In your project, you’ve set an explicit body text style (Scene) instead of using the default (No Style). This means it’s being taken through to Compile which creates a new ‘compile style’ based on your ‘editor style’ - in effect you’ve told the compile to ignore the normal Editor Default (no style) > Compile default body text conversion and to use your style instead.

Because your style in the editor doesn’t have a first line indent, then that’s how the Compile Scene style has recreated it. Therefore the first line indent has to be set in the Style — because you’ve told the compiler to override the normal settings.

Basically, you’ve run into one of the reasons why the manual recommends that you DON’T create your own body text style, but use Preferences > Editing > Formatting to alter ‘No Style’ to your needs — not doing so causes a few extra steps and makes unforeseen effects like this more likely.

That’s what I think is going on, anyway.

Styles appear to style section layouts…

Certainly seems true for your project.

Pleasure. Good luck with the book.

I think you mean my style in the editor doesn’t have a first line NO-indent.

The Editor style does have indents, so I have to override it somewhere. I overrode the Editor Scene style to get justification (no other reason). It didn’t occur to me I’d need to add first line no-indent there, as there’s a layout Compile setting for that.

I’ll try moving Scene formatting to the default style and changing all the Scene paragraphs to “no style” to see if it makes the layout setting take effect.

You’re right – got it the other way round. Doesn’t affect the diagnosis though…

The issue is having an explicit body style – you can set the justification and first line indent for the default in Preferences > Editing > Formatting, of course. It will only affect the editor — by default the compile will format the paragraphs as per their built-in settings, which may or may not include the indent, depending on the compile format. If it doesn’t remove it for the first paragraph, then you’d do so using the method which you tried at first and was being blocked by the Style.

Whether it’s worth converting Scene Style to No Style, now that you’ve got a working format is another matter. If you’re happy with how it is now, perhaps it would be worth leaving it like that and starting again with the next novel…

I converted to “no style” and removed the Scene style from Compile, and things work as you predict. It took a bit of work, but I like to understand how Scrivener expects me to do things.

The message saying styles added in Compile will override Editor styles of the same name is useful, but it doesn’t say it takes precedence over the layout Settings pane, so I’m not terribly satisfied with the user interface of it.