Remove hyperlinks in print format only

How do I remove hyperlinks in print format only so that they appear black without underlining? By the way, in a print format, what is the recommended practice to indicate a link? Parentheses?

Make sure to have those two options unchecked:

As for automatically adding parentheses, that’s a good one. (I’m far from certain that it can even be done…)

But I suppose that it goes with the formulation:
If you said “…see more about this at www.somethingsomething. com”, it’d be weird to put parentheses, and even more leaving “at” just before. So, perhaps there is no need for that at all. Perhaps simply removing the color and underline is just what you actually need.
Or rather use footnotes.

To be planned ahead, I suppose.

1 Like

hmm. I have it unchecked. Yet it shows as blue colored, underlined hyperlink.

I just tried and it worked for me.

Unable to reproduce with the two options unchecked. Even preserve formatting couldn’t force the underline and color to be retained…
I have no clue as to how that can be.

The strange thing is that when I open the pdf file, it shows a blue underline, but when I click on it, nothing happens. It usually takes me to the web page.

In the right-hand pane of the main Compile screen, under the “gear” icon, there’s an option to remove all hyperlinks. Is that checked?

What PDF reader are you using? Is it possible that the reader software is auto-recognizing links?

1 Like

If you know for a fact that your print will be B&W anyways, then perhaps try this:
(On top of having the two options unchecked in Transformations.)

1 Like

I retyped and added thin kinks again. Works now. Strange.

What are “thin kinks” ?
. . . . . . . . .

sorry. typo. the kinks :slight_smile:

oops. typo again. The links. fat fingers.

This is the right and simplest answer to remove links.

That said, it sounds like you pasted from something that not only pastes links, but adds redundant formatting on top of them as well, so you end up with blue underlined text—not because it is a link, but because it is blue underlined text. You could retype them, but it would often be easier to just strip the formatting out in the editor with the text colour and underline tools. The compile setting to remove colour would only handle part of that problem.

But, unless I am mistaken, that was not the goal here. Not to have them gone.

So, if the idea is simply to remove the blue color and the underline, how can the settings I circled in my very first screenshot not be the solution ?
Worst case scenario, if there is some “redundant formatting”, as you say, and the blue font remains, the option to remove color from the compiled output should have fixed it no sweat. Right?

I think that was what was going on. I redid it and it works now.

If the goal is to print, it doesn’t matter if they are actually gone or not, because we cannot click on a sheet of paper to open a link. :wink: Even if you don’t want to print, surely one single checkbox in the project settings is easier to deal with and remember in the future.

But sure, if you want something that can work as both a digital resource and a printout, then adjusting the appearance is a way of doing that. I’ve seen it done, though personally I’d consider two different designs for that, as invisible links are never fun in a PDF reader:

  • One that strips out the hyperlinks and includes the raw URL as a footnote.
  • Another that strips out the footnotes and relies on the hyperlink.

Obviously if one is following a style guide though, they should consult what it suggests for keeping URLs as information, in print. If the goal is to make a citation known, more than guide the user to a website, there is probably something about that in APA.

Note that with Scrivener one has two footnote streams at their disposal, each of which can be selectively disabled in compile settings. This can come in handy for stuff like this, where you might use inspector footnotes for the majority, but inline footnotes for URLs.

Worst case scenario, if there is some “redundant formatting”, as you say, and the blue font remains, the option to remove color from the compiled output should have fixed it no sweat. Right?

If black underlined text is something you’re fine with.

Ok. I see.
My bad, for some reason I thought that the compile option to remove hyperlinks removed the whole thing altogether.
Not leaving it as plain text. As in plucking it out of the paragraph.
As in : For more information on this, feel free to visit

As a matter of fact, after doing a few more tests, I don’t actually know what exactly it removes… lol
It ain’t doing nothing at all… (Something is wrong…)

Ah gee, nevermind. Was chrome bringing it back to life as a link.

Ah! No, you would need something more heavy duty to strip out the text that has a hyperlink added to it, like a style (which is incidentally one way of handling the printed URL on print but not for digital distribution problem).

Or another way of thinking of it, a link isn’t the text it is attached to any more than an underscore is.

So… If I get this right, using the settings from the Transformations panel I did a screenshot of above, allows to make a link look like it is not a link, while it still being a link. (?)

But if you don’t want it as a link at all, the compile option handles and the link, and the way it looks. (?) So you don’t have to bother with transformations at all.

That’s kind of what I get here.

So the only problem here was with a link that was redundantly set ?

So the only problem here was with a link that was redundantly set ?

Yes, this is not an uncommon problem when pasting from certain sources.