Remove Links/Color Issue in Compile to PDF

I’m trying to compile to PDF to submit a manuscript for print on demand. There is some hyperlinked text scattered throughout it, which I’m OK with showing up in the print version as text underlined in black. I was able to do this prior to version by checking remove text color and remove all hyperlinks, but not anymore. It works in some cases, but in others the text still comes through in blue, and with an underline that’s nearly impossible to edit out, even with Acrobat Pro.

Is there some trick to getting this to work right consistently? If this is a bug, have others noticed it?

Uncheck these two in your compile format:

That will leave the links, but remove the decoration.

Or remove only the color ? Not sure I fully understand what you want, since you mentioned trying to edit out the underline…
But that is where it happens.

You might also want to remove the link completely on top of that (it doesn’t matter if it is only for a “to print” version), as some PDF viewer might restore the decoration, if the text of the link is still a link.

In the case where the text is actually a complete URL and the app the PDF is viewed with restores it as a valid link (colored and underlined), I don’t recall what to do.
But I am pretty sure it has been discussed before on the forum.

Vincent, thanks for the feedback. I’ve already got “Remove all hyperlinks” checked, and “underline hyperlinks” and “color hyperlinks” are already unchecked in the compile format. It’s happening despite that. The text is not a url, so Acrobat isn’t restoring it. The compile is correctly removing the links; it’s the residual formatting that’s the problem.

I tried to fix it by editing the PDF in Acrobat Pro, since there are only about a dozen of these in the manuscript. Unfortunately the underline in these cases, which is still blue, is disconnected from the text and doesn’t appear to be editable. I can change the text color to black, but the blue underline remains, except now not quite properly aligned with the text (which makes it look terrible).

I use the same file to compile to Epub, so I’d prefer not to edit out the links in Scrivener if I can avoid it. If I can get the compile to output the word in black with a black underline, that would work for my purpose.

The problem is very similar to this one, which doesn’t appear to have ever received a reply.

Try this:
Find in Scrivener a link that is misbehaving despite the compile options being properly set.
Select the text of it, then Ctrl-X it.
Then, paste it back, but instead of Ctrl-V, use Ctrl-Shft-V. (That is Paste and match style.)
If there is any invisible formatting/link info that was pasted along the first time you inserted the link in your document, that should ditch it.
Compile and confirm.
If it works, do that for the other problematic links.
And always use Ctrl-Shft-V when pasting in a link in the future.
You can still drag URLs directly in the editor, that is not a problem, but if you highlight and copy the link from the text of a website, chances are you carried the underlying formatting (html or whatever causes this) along with it.

To spare you the trouble of making a link back into a link after pasting it, instead of highlight-copy-paste it (which potentially carries all sorts of unwanted stuff – or strips it of everything other than the text when Paste and match style), navigate to the URL in your browser, and insert the link by dragging the URL in your editor. → That works with Scrivener’s compile settings.

1 Like

I didn’t think this would work — but interestingly, I do seem to be able to make some progress with this approach. I should clarify that these are internal document links to sections in a “Glossary,” so I didn’t paste them from a web page or url bar. I inserted them using “link to document” from the Scrivener context menu. But when I tried just “re-doing” a couple, it did seem to resolve the formatting issue. For whatever reason the formatting on these seems to have gotten corrupted, and just “re-doing” them looks like it helps. I’ll follow up to report on whether I can fix them all consistently this way.

Some additional context: I put these links in for the epub, but found that they didn’t work after compiling. So I ended up having to edit them in Sigil afterward. Because of that, in hindsight, I could probably remove the Scrivener hyperlinks entirely, since I had to do them in a post-compile edit anyway.

These are not hyperlinks.



Which I have unchecked, since I don’t want to insert links back to Scrivener for this compile.

(Perhaps not checking this is why the links in the epub compile didn’t work?)

. . . . . . . . . . . .

[EDIT] No. I just verified and that is not what it does.
Sorry I misled you.

But in the present case, I believe that you want this one option unchecked too:

I thought I knew but I don’t.

Something is not adding up.
I can compile with internal links, checking the compile option above, but a) they do nothing, and b) they are blue but not underlined.

I can’t for the life of me either remove the blue, or have them underlined.




I don’t know if what I just demonstrated is in the end related to the OP’s issue (I think it is, but I’m not 100% certain), and for sure I am completely lost now.

You can see link one is not blue and is underline, where my second one, a link back to Scrivener, is still blue and still not underlined.
If the way those documents to documents links look is supposed to be handled elsewhere (and I obviously have no clue where), that is what I believe we are looking for here.


In your compile format, uncheck these two:

And in the compile options, check this one:

And uncheck this one:


OK, after some work on my document, I’m able to report my findings. The good news is that I’ve been able to solve my problem. My solution may bear some relationship to the issue Vincent’s run into.

First, here’s what I found that I had done. As I said, I’d scattered a set of internal document links from the first use of some words in my manuscript to glossary entries for them. These were for my ebook compile, and I wanted to remove the links when I compiled to my print book PDF. I’d found last month that I could make that work with certain compile flags set, which I’ll detail below. The linked words/terms were compiling for the print PDF with black underlining, but I was OK with that. When I recompiled this weekend, however, I found that some of those links and underlines were now remaining blue in the output.

I discovered (with a certain amount of annoyance at myself) that the reason for the persistent underlining was that I’d, well, actually manually underlined those hyperlinks in my document when I created them. When I tried Vincent’s suggestion of just deleting and re-creating them (this time without the manual underlining), both the persistent blue formatting and underlining went away. I went through the document and did this on all the problematic links, and can confirm that the problem is resolved.

I’m assuming that the reason that just “re-doing” those links solved the problem is that the formatting for them had become corrupted, as Vincent suggested. I don’t know if this may have been related to or triggered by my manually underlining them, but it’s possible.

Here are the relevant options I used for this compile:

  • Remove highlighting
  • Remove text color
  • Remove all hyperlinks

Here are the relevant options I made sure were not selected for this compile:

  • Underline hyperlinks
  • Color Hyperlinks
  • Convert document links to link back to Scrivener

I’d like to thank Vincent for his extensive feedback, which was instrumental in helping me figure out how to solve my problem. I hope the information I just provided helps with any remaining issues he’s found.

Tony Andarian