Remove Revision Color Doesn't Work

I did a revision of my manuscript, and now I can’t remove the red color from the changes. The option to remove the revision color is grayed out.

Not at computer but are you in the document? I would highlight select the document and suspect will be able to revise/ remove the colors

I’ve tried that. When I’m in the document, and I select the text, the option to remove the revision color disappears and is replaced by the option to remove revisions, which I don’t want.

If I’m not mistaken, I believe when revisions is on, the text color(s) stay in your editor. However, they will not show up when you compile.

98% sure is a setting in the third compile panel under settings to leave in or remove at compile

The phrasing, “remove revisions” does not imply that all text that is marked with that revision will be deleted, but the markings will be deleted. I’m pretty sure that’s what you want, but do note that if you select Level 1 (red) first, and then look at that menu, an option will be added that is more surgical, removing only that level and not all level markings (if that is what you mean).

These commands do not require a selection. They will operate within a selection if one is given, but otherwise will impact the entire section the cursor is in.

The only command that actually deletes text is when you use strike-out, and then Edit ▸ Text Tidying ▸ Delete Struck-Through Text. That one does require a selection.

2 Likes

To test, I added a test scene with dummy text and marked some of it red as a first revision. I was able to remove the red in that case. Then I tried the same thing on a pre-existing scene, and was unable to remove the red. I even changed red to black in the revision options. Still nothing.

I just want to get the red off my screen and go back to black without losing any changes. I have unfortunately revised 59 scenes this way, and I can’t get rid of the red on them. It doesn’t seem to matter whether I select the document, or the text in the document. The red just won’t go away.

Were these all made in the Windows version, or do you swap between iOS or Mac now and then?

The red revisions don’t show up when I compile, when I check the box to remove text colors. But I’m nowhere near done with editing this book and compiling, and I just want to remove the red text and go back to black.

Yes, the whole document was created in the Windows version, on my PC. No other versions or computers were ever involved.

Hmm, curious, that kind of result should not be happening in the Windows version, which uses special invisible markers to indicate revision levels. The colour is just an effect coming from those markers. (The Mac on the other hand has no such markers and relies solely on the precise actual RGB colour being the same, and so it can very easily get confused in a manner like you described).

Are you sure they are revision markings? Do they respond to the command to remove text colour? You can test by selection some text with the red that won’t go away, right-clicking and selecting Text Color ▸ Remove Color. True revisions won’t respond to that, because again the colour is just an way of seeing the marking being there, rather than actual text colour.

All of these red markings were made by revision. However, I just found a way, although it’s quite laborious, to get all of my text back to black again. I had to go into each of 59 documents one at a time, select all the text in it, and change the text color to black. That worked in all but one case, and in that case I was able to use the remove revision method.

There’s definitely something buggy going on here, but I’ve taken care of my problem, and I promise never to use Revisions again.

Do you by any chance have a backup of this project prior to the fix you mention, that we could take a look at? Honestly even just one section that exhibits the problem, one paragraph within it, would be enough. Such could be dragged into a new blank project, and tested there to make sure the original problem you noted still persists. Then, if it does, use File ▸ Back Up ▸ Back Up To... to create a zipped copy, which can be sent either via email to technical support, or as a private message to me, by clicking on my avatar and then the big Message button.

It does sound like a bug for sure, but I don’t see anything in our ticket database that indicates we know anything of it.

Regarding the revision color problem, here are a couple of scenes from my manuscript, as of yesterday, which I’ve copied to a blank project and put in a zip file. I hope this works.

Scrivener Revision Problem.scriv.zip (346.4 KB)

1 Like

Many thanks for putting that together. I can certainly see the problem from looking at the raw formatting codes, there are two of them in fact.

  1. Firstly, it is as I suspected, all of this text is not marked with the special *\scrrevlvl1 tag, which is what we use to recognise that it is a revision marking and not just red text. It is marked red as well, which is what makes it compatible with other word processors if you copy and paste it out, but important to note there, doing so may not always preserve that special tag. RTF editors are supposed to, that is what the asterisk in front means, that it is custom tag another program wants to keep. But no editor is obligated to respect those and may strip them out, leaving only the colour.
  2. So for this reason (and because of the Mac version), we do have a fall-back behaviour meant to recognise a revision purely by its colour. That should have, in this case, saved you, but if the settings colour changes, or the RGB colour in the text itself, then that fallback ceases to work.

So not only is the file missing all of the invisible revision markers, the colours are all “wrong”. They are using “true red”, which is the Red channel turned all the way up to maximum, and the Green and Blue channels turned all the way down to zero. Assuming you are you using the default revision colours, the actual colour should be 251 (out of 255) for Red, 0 for Green and 23 for blue. It gives it a slightly softer and more orange look.

The software no longer recognises them as revision colours in that condition. You could however salvage them, by setting your preferences to true red for level 1. That would cause the fallback behaviour described above to take effect, and since all the markings are 255/0/0 and so are your settings, they get stripped out.

So that’s how you could have fixed it.

As for how it got that way, I don’t know! I’ve never seen Scrivener for Windows lose its own markers like that, but like I said there are certainly ways they could be lost. Exporting to something other than RTF for example, like DOCX or ODT, and then importing later, or copying and pasting into a badly designed RTF editor that strips out every marking it doesn’t understand (like the Mac/iOS text engines, which Scrivener depends on there), etc. Perhaps something along those lines rings a bell.

If that’s definitely not a possiblity, then yeah, there must be some bug, but unfortunately there is no trace of whatever caused it left in the file. Like I say, at this point, it’s just red text in the editor, text you can clear with the Remove Color command I mentioned.

The only slightly weird thing I noticed is that there are about half a dozen instances where the real revision marker itself was in the text, but they only exist between paragraphs, where a line was left empty. That’s kind of a clue I guess, but not a very good one!

1 Like

Well, I know I didn’t export any file and then import it later. All these scenes have been created and have been in the program for a long time. This project is two years old by now.

In my futile effort to get rid of the revisions efficiently, I did change the revision color back and forth a couple of times, but that didn’t help. What did help was going into every scene, one by one, selecting all the text, and changing the text to black.