Replacing italics with *italics* for Word export

Hi everybody,

my editor works with MS Word, she wants a Word document with all italics either in markdown word or as a Word format preset (whatever that is).

I don’t own Word, so I’d love to compile to Word from Scrivener and replace my Italics with the markdown asterisks.

There used to be a menu function in Scrivener: Format → Convert → Italics and Bold to Markdown, but that has disappeared.

In Compile, I can do this, but just by exporting the MD format, which she doesn’t want.

Is there any way to do this? Just couldn’t find it in the manual.

Thanks!

JS

I think the answer to both questions might be the same, assuming I’m understanding what a Word “format preset” is—they probably mean styles. In Scrivener you can use styles instead of bold or italics, even if just to do only that (the built-in Emphasis style for example). And of course these will export as styles into the document, so that may be all you need to do to satisfy what they want.

But if they do prefer Markdown notation for these, that wouldn’t be a problem either. A lesser known capability of Scrivener’s style system is the ability to put text around styled material when compiling:

  1. Double-click on the format you use to compile, in the left sidebar of the compile overview screen, to edit it.
  2. Select the Styles compile format pane.
  3. Click the + button in the top right area, and add “Emphasis”, if necessary.
  4. To the right you will find some options for how to handle the style. The Prefix and Suffix fields would be where you put your asterisks.

Thanks so much. Yes, that should probably to the trick. Is there any fast way to convert the many instances where I used cmd + i in my manuscript to the style »emphasis«?

And while typing, how do I apply the style without using the mouse / trackpad? (Edit: Got this one: – “ChangeKeyboardShortcut”:reassignsthestylesshortcutwith- out having to go through the “redefine” panel.)

Thanks again, JS

Oh, whew, as for fixing this after the fact there isn’t a good way. Best would probably be to use the Edit ▸ Find ▸ Find by Formatting… tool, set to “Character Format” mode. Then you can alternate between ⇧⌥⌘G (find next formatting match) and your style shortcut. Hopefully you don’t have hundreds!

Regarding shortcuts, as you note you can change the shortcut on the style itself, but some people even like to reassign ⌘I over to the Emphasis style, since that’s such a habit, using System Preferences.

Thanks again. Well, it’ll be around a hundred, but any Zen exercise is repetetive. I’ll try and assign cmd + i to the style emphasis in system prereferces, let’s see if I get this right …

Thanks again and sorry for the delay in replying. I’ve assigend cmd I to »Emphasis« in System Preferences as described. It works, but only sometimes. Sometimes it will just do Format → Font → Italic, as before. I haven’t found out if there’s any pattern to when it works and when it doesn’t. I have now assigned a different shortcut to »Emphasis«, but it doesn’t toggle the style on / off, so I have to manually go back to the style »No Style« every time. Is there no way to do this? Thanks again! JS

I haven’t heard of that happening before, my only guess is that there is some kind of timing issue where the styles menu takes a moment too long to activate, and so in that moment the command does not exist, and thus the custom override fails and the system falls back to using the software default for the shortcut. I suppose one thing that might cause the menu to “refresh” is if you have multiple projects open and switch between them often—but maybe it does a quick refresh whenever activating Scrivener. Not sure, but I suspect if you used any default shortcut you would find the same behaviour (for example if you use Opt-Cmd-R then the error would Reveal in Binder instead of modifying the text). It’s all a wild guess, though.

As for the second question, I believe there are some awkward corners where character styles do not work precisely like direct formatting tools, yes. In simple cases, like typing and turning the style on and off as you type, it should be fine, but I recall their being some issues with it not always working like direct formatting, or styles in other word processors for that matter. I’m being vague, because I used to run into those as well, but at this point my brain doesn’t try to do those things anymore, so I’m having a hard time coming up with examples. :laughing:

I confirm that I’ve run into this before, and assigning a shortcut—any shortcut—to Font>Italics fixes it.