Resetting chapter numbering for different books within a trilogy

Hi all

I’m working my way around the Scrivener 3 settings but there’s one thing I can’t work out how to do. To be fair, I never needed to do this before, so not sure if it’s something that’s even possible.

I’m compiling a trilogy, and have assigned the book names as different ‘parts’ with the chapters of each book nested within them. The only problem is, the chapter numbers carry on from book to book, so chapter one of book two is listed as chapter 29. How can I get the compile tool to start the chapter numbers from scratch after being separated by a part? Is this even possible?


I assume you’re set the project up in the Binder so that the Books folders has been allocated the same Section Type which only they share (for out purposes let’s say you’ve given them the Part section type).

[BTW, if that sentence doesn’t make sense, then the absolutely best thing you can do now is to do the Interactive Tutorial and look at the Collection ‘What’s new in Scrivener 3’. It won’t take long, but it will introduce the new concepts on which Compilation is based – it will be worth the half hour it will take you :wink:]

Assuming then that you’re set the Section Types up properly, all you need to do in Compile is to choose a Section Layout for the Part Section Type which resets the included Chapter numbers to 1.

If there isn’t one already available, (I don’t think the defaults provided do this) it’s easy to add. Say you’re compiling to PDF -> Paperback. Right click on Paperback and choose Duplicate and Edit. This bring up a full range of options you can edit.

Choose Section Layouts, then find the Chapter with Title Section Layout. In the panel below click Title Options and you’ll see the following code:

Chapter: <$t:chapter><$rst_scene>. This code tells Scrivener to print the chapter title as Title Case words ($t:chapter) — and to reset any Scene Numbers from this point. So by default, Scene Numbers are reset on a new Chapter — but you want the same behaviour for Chapters in new Parts.

If you click on the Part Title Page layout and look at the same Title Options panel, all you have is Part <$t:part> – the reset code is missing and this is why your chapter numbers are cumulative throughout the books.

All you need to do is add it in — but instead of <$rst_scene>, we need <$rst_chapter]> because obviously, it’s the chapter numbers we want to start again for each new Part/Book.

Press Save, make sure you’ve allocated all your section types to the right layouts, then compile.

That’s the basic process: add <$rst_whatever> in the heading of the section type which is the parent of the one whose number you want to reset.


Cheers. I actually found a solution on Scrivener 2 and retrofitted it. In S3 it’s actually pretty basic. If the books are seperated as parts, you just need to go into the Part Title Page on Section Layouts and add <$rst_chapter>. That does the trick!

I think that’s what I said… :smiley:

I’m glad it worked for you.