[Resolved] This is a debugging window that displays a visual representation of constraints

Hi, Since I installed the latest update of Scrivener, I’ve gotten a purple frame around my window, with some debugging text. I see arrows on one of my documents. When I click on the help button in this frame, it says “This is a debugging window that displays a visual representation of constraints”.

How do I get rid of this, please?

1 Like

You are running Scrivener 3.3.1 ?

yes i am running 3.3.1

That sounds to me like some kind of third-party thing that you have installed. I searched the web for the phrase you quoted, and came across this utility, which has a ticket with a screenshot that looks a lot like what you describe.

Edit: a colleague found another discussion thread that is even more informative, which indicates it may be some kind of flag left on in the software. Someone did post some command-line settings you can use to disable it. We’ll take a look at the compile settings though.

1 Like

Just installed 3.3.1 on a 2015 MacBook Air running 12.6.3

There’s a pink/purple debug window and messaging around the top of the app that says “this is a debugging window that displays a visual representation of constraints”

Screenshot below.

1 Like

Got the same on my macbook 14 pro today.
Both the system & the app are up to date.

I’ve got a completely broken Scrivener, as of my update today. I can see my current project but can’t interact with it at all because there’s a purple screen overlaying it which says “Layout is ambiguous” at the top left, then “Exercise ambiguity”.

MacBook Air, using Ventura 13.2.1

I’m still having this problem also, although if I restart scrivener it works. If I go to the top menus and choose fonts I get the purple screen and have to close scrivener. I’m not changing font for the time being. I’ll report back if other actions cause this.

I’ve merged the two separate threads on this same report together. Please note the link to another discussion forum above, where some commands are shared that should suppress the appearance of this tool. You would of course want to substitute -app 1Password\ 7.app with -app Scrivener.app, wherever it appears.

I have no way of testing any of this, so I’m just passing along information others report having worked (it looks like at one point Apple’s iPhoto did this as well, and people used the same trick to get rid of it).

I used the command in my debug window and it still comes back when I restart scrivener

What is this referring to exactly, as I don’t have a “Fonts” option in the main application menu. There is a Format ▸ Font ▸ Show Fonts menu command, but I don’t see this problem when I use that (or the keyboard shortcut).

Can you change the font with the Format Bar instead? That might be a suitable workaround for now.

I don’t think the hint in the box is accurate, because when I tried scanning Scrivener’s preferences for the key it mentions, it wasn’t there. Thus running the delete command that it suggests wouldn’t do anything.

What might work better is:

defaults write com.literatureandlatte.scrivener3 NSConstraintBasedLayoutVisualizeMutuallyExclusiveConstraints NO
killall -u $USER cfprefsd

The first command adds a directive, and the second flushes the preference cache so that .plist file is forced to be read. Obviously this all needs to be done with Scrivener closed.

That will add the key to Scrivener’s preferences with the directive to not use this feature. I can’t test whether it works though as I don’t get this problem save for one case in the Help menu search. This doesn’t change that, but I’m not 100% positive it would, as the help search tool is added by the system rather than coming from within Scrivener.

1 Like

Yes I meant There is a Format ▸ Font ▸ Show Fonts menu command. So far changing the font via the menu bar is working. I may try running the commands you suggested. Thanks!

Let us know how it goes! I suspect it may not fix the font box though, for the same reason it doesn’t seem to fix the Help search field—both of those are coming from Apple, so they may be bypassing any blocks at the Scrivener level. That’s just a guess though.

I’m new to Scrivener, and currently going through an online course on how to use it. When I toggle between “text” and “icon and text” in the toolbar, I get the same purple window others are seeing. How exactly do I fix this? I am using Scrivener 3.3.1 on Ventura 13.2.1 Thanks!

What does the “same purple window others are seeing” look like?

Same for me (on Ventura 13.3) when I do that:

@drmajorbob It looks like this.

1 Like

Figure out which 3rd party (non-Scrivener) app is causing it and squash it.

1 Like

Thanks for this useless and unsolicited “advice”.

1 Like

Thanks for your unsolicited critique. I’m pretty sure what I said is what you have to do, but you probably wanted me to figure out what 3rd party app is involved and how to squash it. I won’t do that for you (how could I?), but maybe someone else will.

1 Like

I didn’t want anything from you, the only reason I mentioned you is because you asked “What does the ‘same purple window others are seeing’ look like?”. It looks like this. Do with this information as you please. I don’t expect you to fix it.