RESOLVED: Turn off automatic periods when adding a space after a single letter

When I wish to type a series of letters with more than one space between them Scrivener automatically enters a period after the last entry. I can’t find a place in Settings to disable it. I’m writing a script which includes a series of chord symbols:

A. D- C. F.

What you see is the result of normal typing.

This is what I need:

A D- C F
I need a double space between letters. If I use a single space between letters it doesn’t automatically enter a period. It also doesn’t enter a period after the dash. If I enter more than one space I have to backspace and delete the periods in order to get this formatting. It’s maddening. And, BTW, it’s not consistent.

How do I turn off this behavior???

SOLVED: It has to be turned off in Mac OS. From Scrivener Settings / Corrections, hit System Text Preferences. Then, hit Edit and turn off “Add period with double space.”