rtf formatting

One of the main ways in which I use Scrivener is to download a document from a web site that I use, in rtf format and then import that document into a Scrivener Research folder.

Today I have found that documents imported this way end up with strange formatting (I don’t remember having this problem before the update to the beta). This happens where the original document has a footnote, with a superscript number in the text referring to the footnote. When importing, the text following the (first) number takes on the superscript until the end of the document. There does not appear to be any way to change the text back to normal.

The workaround is to select Document -> Convert formatting to default text style (using Convert font only), which puts the whole document in a single text style and the whole thing becomes much more readable. Of course, I then lose all of the bold and italic text as well.

Can this be fixed? Or could you put in an option in the import box for it automatically to be done?

Thank you.

I have now tried the “preserve font style option” and this preserves the bold and italic passages.