Ruler settings changing themselves

I’m having a problem where, occasionally, in some documents, paragraphs will audo-indent all but the first line of a paragraph.

It looks like this roughly:
(Edit: Formatting isn’t sticking. Basically all but the first line are indented about half an inch)

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Vivamus sit amet arcu non nulla lobortis suscipit. Sed pulvinar
feugiat est, eget interdum lorem congue mattis. Aenean pharetra eros vitae turpis aliquam, nec maximus erat
vehicula. Morbi rhoncus fermentum sollicitudin. Cras ornare tincidunt leo sed egestas. Cras non sem odio. Proin
pharetra lacus nec diam sollicitudin mollis a quis nisi. Aenean finibus nibh sed augue viverra malesuada

I can adjust the indentation with the ruler, once it starts happening. But then it will still auto-indent the next paragraph I type. I don’t know how to turn it off entirely, or why this formatting is getting turned on in the first place.

I suspect I might accidentally be using some keyboard shortcut from some other program automatically? But if so, I can’t figure out which one or how to quickly undo it once it starts.

Any help would be appreciated!

The relevant commands can be found in the Format → Paragraph → Tabs and Indents menu. Once you’ve formatted one paragraph to work the way you want, you can use the Project → Project Settings → Formatting pane to make it the default for this project, or Scrivener → Scrivener Preferences → Editing → Formatting to make it the default Scrivener-wide.

Then, the Documents → Convert → Text to Default Formatting command will reformat existing text to the new default.

If you’re getting mystery indents and aren’t sure why, use the View → Text Editing → Show Invisibles command to look for tabs and similar white space.