Ruler weirdness and confusion

I’m having trouble setting the ruler/margins.

  1. In the tools/options dailog the right “pointer” is missing. (see image)
  2. In the editor, the margin is set to 6.1xx (or thereabouts)
  3. When i compile the project, the margin is 6.5.

What I want is simple.

  1. In the editor, for all text document in a given project, i want the text to be 6.5 inches wide. (equivalent to standard, 1 inch margins)
  2. I want the text to be more-or-less centered in the editor window. (i.e print layout view in Word)
  3. On compile, I want to retain the 1 inch margins.

I tried to set the margin using the Tools/Options dialog under settings. But the little window is too small to set the margin to 6.5. (see image)

I also tried using the “Editor Margin” setting, but that also effects the vertical spacing, which is, to me, undesirable. I just want to move the text to the right so it’s centered. (#2 in my “wants”) I can resize the binder window to make it bigger and that moves the text window over, but i’d prefer just white margin (editor whitespace) on the left side.

In a related issue, the “Default Main Text Attribues” window is effected by the Editor Margin setting which is why the ruler doesn’t go to 6.5. If i set Editor Margin to 0, it maxes out at 6.33 (give or take.)

Finally, I’m unclear how the editor formatting values effect the compile formatting values. Or are they the same thing? If, for example, I wanted to set the in-editor ruler width to 8 inches, so I have a nice long line of text to edit in my wide screen monitor, but then compile it to have a standard 6.5 inch line of text, would I have to change the editor ruler and then compile or are there a separate “compile” format settings?


Firstly, to clear up one point of confusion, this marker is not a margin indicator but an indent indicator. Margins are what define the limiting of the main text block, and indents are what modify that temporarily, to pull text inward from the edge of the page. You do not, in nearly every single case, want to be applying a right-indent to your text. I know that’s a bit unusual and maybe old-school, since a number of modern word processors have conflated these two things in the ruler.

Secondly, you will note that Scrivener’s ruler starts at 0" on the left, and not at wherever your margin offset would physically have it, on the paper. Again, this is because the left arrow, like the right, is an indent marker. It operates relative from the main text block, or the margin, not the physical sheet of paper.

This is one area where working in Scrivener is quite a bit different than in a word processor, where you type into a simulation of the printout. The main editor is quite clueless on such things as paper sizes and even margins, and makes no attempt to even simulate them. When you are writing in Scrivener, you are just working with the words, not the document—a subtle but important distinction. Everything you type into the editor will later be coerced into a document when you compile, and it is only at that time that things like paper size and margins will be defined. It makes more sense when you think about it vertically, because in Scrivener a block of text in the Draft may only be a paragraph or two long, even though it is part of a much larger (taller) section. You can almost think of Scrivener more like a database with bunches of little chunks of text that get assembled into a document when you compile.

The implication of this is that you aren’t actually setting a right-indent of 6.5“ in paper terms, because this ruler doesn’t even start at the paper’s edge, but rather somewhere off of it, as defined by the margin. This will more likely be something like 7.5”, which would fall completely outside of the standard printing area, and in some cases can even glitch out word processors you export to, causing text to run off the page.

Whether you need to ever use the right-indent marker at all is one thing, but I would say in pretty much all cases, you would never want to set that up as a global default. If you need to add universal padding to the right hand side, that is what margins are for. So that you cannot see the marker in the global settings (which I do agree is a bit of a glitch here) is of minimal importance.

As for the editor margin, as I believe you picked up on, that is just an aesthetic choice. We do plan to introduce an aesthetic model that mimics a printed page (though not designed to represent physical pages because, again, text in Scrivener really isn’t “a document” until you compile). We also will be implementing the ability to simply cut the editor off at a certain width, so you can still dispense with the “paper” notion, but have a comfortable line-length on large screens. This mode will use a padding colour on the left and right, or just on the right if you want the text pinned to the left.

Right now experiment with working with a narrower window, and using the visual editor margin to keep things easy to look at. Some people also keep vertical splits open, or the Inspector to help keep the editor line-length readable. Scrivener’s editor is going to be more like Notepad, than Wordpad, to put it to a comparison. Some people actually like that. :slight_smile:

They don’t. At the very most what you see in the editor can be simply passed through the compiler without being changed (but this has no bearing on the compile settings themselves). This would be more like using a typical word processor. What You See is What You Get, Mostly. However most of our templates and presets operate on the philosophy that one needn’t worry about such things as the precise point value of their font, and having to stare at TNR all day, just because that is how it is going to print. So the editor formatting usually defers to your compile settings. The Formatting pane is where body text and heading attributes can be set up, in a box very similar to the default editor settings in Tools.

The main exception to that is if you’re going to be working in non-fiction, or anything that requires a lot of inline formatting, such as block quotes. Then you’ll need to be passing formatting straight through the compiler and will have to set up your default editor formatting to match the output. There is a global switch for that at the top of the compile Formatting pane if you need it.

Right, that would be a function of margins, not indent. Margins are set up in the Page Settings compile option pane. There you set up the physical paper size as well as the main text block. As with the editor, the ruler settings in the Formatting compile pane have to do with indents, and usually you wouldn’t want to mess with those on a global scale (save for first-line indent, naturally).

You could set your global indent to 8" to constrain the editor width, and live with the whitespace on the side, but do make sure if you do that to override formatting in the compiler, so you don’t have text flying off the page in your RTF files. I’m not sure what advantage that would have over using the window width the hand word wrap, but I’m sure that’s just a matter of taste.

Wow, thanks for all that detail. It made a lot more sense after the first line. :slight_smile: I was thinking of them are margin markers. I’m not quite sure how my brain make that mistake, I guess because it was late. I does help to think of the editor formatting as separate from the output. I didn’t realize that was the case.

I was just about to ask you where to set the output formatting when I discovered the “expand” arrow on the Compile dialog. I didn’t know all those formatting options existed! Ok, it all makes sense now. I was thinking of things in terms of a typical word processor. All I ever did was print, I don’t think I ever actually compiled a document.

So, as I understand it now, I can setup the editor in a nice friendly way to make editing easier and then reformat the output by using the compile option. But If I just Print, it uses the setting in the editor. Is that correct?

One other question. Is there a way to remove or expand the right indent marker so that the text in the editor goes to the right edge of the editor window and have that setting the same for all the text in my project?

I can’t find it in the Tools/Options/Editor setting dialog and I’d like to reset it to the default.

You’re welcome!

That’s something we need to improve. It’ll be more obvious once we get that sorted out. I do agree it’s a bit obscure at the moment.

Exactly the idea. What works best for a 3am writing session with bloodshot eyes may not be what you want to hand over to your editor. :slight_smile: It also means you don’t have to worry so much about getting everything just-so while writing. If you’re a neat freak like me that won’t appeal, but some people like that you can just be messy without consequences, assured it’ll all look tidy and professional in the end.

That’s a good point, but do note you can also use the compiler to print. That is one of the “Compile For” modes. Whether that is convenient depends on what you typically do though, and how you use the binder. If you usually print out sections of the draft with Scrivenings mode, you can just use the Contents compile option pane to select the group, using that drop-down menu at the top. It’ll be less convenient if you usually just print out one individual piece at a time though. For myself, I rarely use regular printing because I write into very small sections in the outline and nearly always need a group of items together—so compile is just as well. But if you tend toward longer files, the opposite may hold true.

At any rate, you have two possible printing tools to give you a little flexibility in how you work with text at the editor level.

Just drag it all the way to the right, into the light-blue area, you’ll know it worked if you resize the window and the triangle “floats” instead of staying fixed to one position.

To get around the glitch in the default settings, you may need to temporarily remove the editor margin so that you can see the indicator again. It may already be fine though—to test just make a new document and see if resizing the window causes the indicator to track with the window width instead of staying fixed.

All that you wrote is very helpful. I didn’t know there was a “Compile for Print”, I’ll have to give that a try when it seem appropriate.

Thanks again.