Running Scrivener on Debian 7 Wheezy


I’m having a bit of trouble running Scrivener on Debian 7 Wheezy, AMD 64 bit.

I’ve installed the program with:

su -c "dpkg -i --force-architecture scrivener-"

Given that I need 32 bit architecture to run, I’ve tried to use the ia32-libs, but those are depracated on Debian 7. You can’t install all the packages, and just mess up the package table in the end.

In Debian 7 apparently you have to add this, running as superuser:

dpkg --add-architecture i386
apt-get update
apt-get install -f

However, when I try to run Scrivener from a terminal, this is what I get:

The files and folders do exist. Anyone have any ideas?

Thanks in advance.

Apparently you have to install ia-32 libs after the add-architecture:

sudo dpkg --add-architecture i386 sudo apt-get update sudo apt-get install ia32-libs

You might also want to run this in order to clean up the package system:

sudo apt-get -f install


If you still get the “not found” error, run ldd on the binary and see if all of the required libraries are present:

bash$ ldd /usr/share/scrivener/bin/Scrivener | grep -i 'not found'

Thank you for your reply. I did things your way. This is the response I got.

root@Ragdoll:/home/max# ldd /usr/share/scrivener/bin/Scrivener | grep -i 'not found' => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found

Maybe I should reinstall Ubuntu and just accept that Amazon get all my data :smiley:

As far as ubuntu goes, just don’t use the default window manager (unity). Use GNOME, KDE, XFCE, Fluxbox, or (my personal favorite) e17. That should keep your data from being sent to Amazon (though I can’t say for sure, as I only use command-line utilities to search my system).

As for the missing libraries, it looks like a few packages need to be installed:

sudo apt-get install libglib2.0-0:i386 libgstreamer0.10-0:i386 libgstreamer-plugins-base0.10-0:i386

The way to find the packages for these libraries is to find the 64-bit versions, then use dpkg -S to find the package that owns the 64-bit file.

For example:

bash$ find /usr/lib -name 'libgstreamer*' /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/ bash$ dpkg -S /usr/lib/x86_64-linux-gnu/ libgstreamer0.10-0: /usr/lib/x86_64-linux-gnu/

The 32-bit package will have the same name as the 64-bit package, with ‘:i386’ appended.

Thank you so much. The installs of those packages did the trick. Guess I won’t have to go back to Ubuntu after all. Scrivener is a key program for me, and I’d like it to work. :laughing:

I just don’t like having big data miners in my computer. It’s enough to have to suffer them on Google and elsewhere. I don’t want them inside my OS. :slight_smile:

Now you have the fun task of making multimarkdown and spellchecking work :wink: