Running Scrivener on Linux

This is just a link to the already well established wiki page on the topic: … r_in_Linux

This page contains a how-to for WINE, as well as running it natively, and getting the tutorial working.

Does anyone know when the wiki will be back up?

Should be pretty soon now. I’ve got the replacement set up; and just need to fix the stylesheets a bit so it doesn’t look like a sore thumb.

Thank you :smiley:

I am wondering if this wiki still up to date? The instructions for the native version are for a zip, and they do not seem to work for 23.
Are there instructions somewhere?

Thanks for the help.

Actually…for wine-scrivener, I don’t think the dll’s are necessary anymore, just the stuff via winetricks. I just installed Slack 13.37 to my laptop, didn’t copy them over, and things appear to be working fine.

I apologize. I mean for the Linux native version, not Wine. The instructions on the wickey seem out of date.

I’m new to Scrivener and new to Ubuntu as well. I followed the manual install instructions that are currently on the wiki (recognising that I had to use ‘tar’ instead of ‘unzip’) and I think everything worked as it should.

But typing in ‘scrivener-beta’ in terminal gives me a “command not found”. Has the command changed? Is the command directory dependant?

I would like to try out Scrivener on Linux to see if it’s able to create EPUBs as I was inspired by this post: … scrivener/

Depending on how you installed it, yes, it can be directory dependent.
One method for finding the needle-in-the-haystack, if you have no idea where the executable/application is, is to do something like this:

[code]sudo updatedb
locate -i scrivener | egrep bin

or possibly

locate -i scrivener

The beta 24 tarball has the executable in:


Just untarred it myself, used the shell script mentioned here, and it runs like a charm. Speedier than earlier builds, I think.

Dang near as easy as the .deb. (I use Ubuntu 10.04.)

Oh, and if you want launcher-y goodness, I mocked up a logo:

(save the image file; I saved it to ~/.icons ). Fire up your favorite text editor and edit:


[Desktop Entry] Type=Application Name=Scrivener Exec=/home/USER/PATH/LiteratureAndLatte/bin/ Terminal=false Icon=/home/USER/.icons/Scrivener_Logo.png Categories=Office;

Awesome. Thanks for this and for the instructions.

OK, I am having flashbacks of editing FORTRAN code in college (yes, I’m that old). I get the basic idea of the Terminal (I’m running Ubuntu 11.04) and I’ve tried to follow all the instructions I can find, but I’m not getting the program to run. So instead of writing my novel, I’m typing, copying and pasting endless lines of code only to be told, in polite computer language, that I’m an idiot and have no idea how to do this properly. I’m very happy to no longer be using Windows, and I love Scrivener, I just need to get going. If there is someplace to find step by baby step instructions, that would be great. Thanks for all your hard work and happy that there is a Linux version.


First - are you using the .deb package or using the tarball? The instructions and help will be a bit different for each.

Would you mind telling us exactly how it’s telling you that it’s an idiot? (I’m hoping for “scruffy nerfherder”, but…)

Seriously, though, the precise error messages will help.

I got Scrivener installed, I think, but cannot either locate the file to get it to run, or I have not installed it correctly. I tried a .deb file, but Ubuntu told me the file was corrupted so I downloaded the tar file and went that route. I have tried both the Download directory and putting the file on the Desktop, but neither seems to work. I copied and pasted the codes directly from the wiki and the forum, but apparently I’m not doing it right. It says “Command not found” or “File or directory does not exist”. I know this is not beyond me, I just need step by step directions (cut and paste code is a bonus) and I will get this. Your help is greatly appreciated (your cookies are in the mail).


It doesn’t matter where you put it. What matters is that the system can find it. If you look at this:

echo $PATH

It tells you everywhere the system will look to find a command when you type it without using an absolute pathname.

My system outputs this:

echo $PATH /home/nathan/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games

Notice “/usr/local/bin.” By convention, that is where binary executables – or links to them – that you install would normally go, although there are competing conventions.

Do this step, where “” is wherever you decided to unpack the tarball (the instructions in the Wiki are for /usr/local/LiteratureAndLatte):

sudo ln -s /<directory>/bin/Scrivener /usr/local/bin/

What you’re doing is creating a symbolic link from the absolute pathname of the Scrivener binary executable into the /usr/local/bin directory, so that “/usr/local/bin/Scrivener” will be there for the system to find when you issue “Scrivener” as a command form the CLI or using some other means. For instance,

which Scrivener

should output something. Note that if you install the .deb package, it puts Scrivener in /usr/bin. If you don’t have /usr/local/bin in your PATH environment variable, change the “ln -s” to point to /usr/bin instead. You can also change your PATH variable, but that’s another topic entirely.

You can create a desktop file like this:

[Desktop Entry]

and double click on it to launch Scrivener. You can add an icon, too, but figuring out how to do that is a different kind of fun altogether.


Progress! I can get Scrivener to open, and start a new project, but I can’t open my existing project which was done on the Windows version (2.9) of Scrivener. I haven’t tried going the other direction yet, but a step forward is a good thing. All of the help is greatly appreciated.


Success of a sort. Can get Scrivener to load from the terminal and have even been able to open my project created on Windows (which was not working a few days ago, cue Twilight Zone theme). Pasted the code for the desktop icon, that did not work, but typing “Scrivener” into the terminal is a small bother. It seems to take all the code just fine, but the final line says: “Office: command not found” Computer still smarter than the human using it at this point.

Here’s where things take a left turn. When I have Scrivener open, if the window is maximized, the menu commands won’t respond i.e., File, Edit, etc. Point and click and nothing. If I make the window smaller, they work just fine. I can load in a project, then resize the window and we’re off and running. This feels like a bug, but given my experience thus far, I’m not ruling out human stupidity (mine, not yours).

I am still preaching the gospel according to Scrivener on Twitter, Facebook and my writers group, (people on the train and in the park look at me strangely, but at least I’m not telling them to repent, just write easier). Looking forward to getting everything 100%, up to and including the awesome little penguin logo sitting on my desktop (baby steps, have to take baby steps). This is not the easiest way to learn an operating system, but with ADD… Shiny!.. it’s the only way I know how. Thanks for the help, have a great weekend.


Here is the contents of my scrivener desktop file:

[Desktop Entry] Hidden=false NoDisplay=false Exec=/usr/local/LiteratureAndLatte/bin/Scrivener Type=Application Version=1.0 Categories=Office; StartupNotify=false Name=Scrivener Icon=/usr/local/LiteratureAndLatte/Scrivener_Logo.png Terminal=false

Create a file on your desktop (from the terminal, this is the directory ~/Desktop) and name it Scrivener.desktop. Make sure to replace “/usr/local” with the directory you unpacked the Scrivener distribution to (it sounds like the same).

If you’re using GNOME, you should be able to right-click on the desktop and create an ‘application shortcut’ (I think that’s what they call it) instead of having to make a .desktop file manually.

If you create it via console edit (or other text editor) remember to make it executable by owner via Properties -> Permissions or by

chmod +x <path to the .desktop file you just created>

If you do it by (on the desktop) left click -> Create Launcher… you can skip this step.

Another fun tip: if you have KDE installed, you can run .desktop files from the command line using kioclient.


kioclient exec file:/usr/local/LiteratureAndLatte/Scrivener.desktop