Saving bug - Autosave or Ctrl + S won't work [solved]

Hello everyone,

Recently bought Scrivener and encountered this bug today : the autosaves or normal saves will not work. As soon as I modify any text document, the following message comes up :

“Could not save project document
Failed saving text for document with ID {XXXX}
Error : Could not rename project rtf to .old rtf file name.
File : {XXX}”

It does mention that it might be because I’m out of space on my storage device, but I know that this is not the case.
I don’t really know how I can give the app the right authorizations to rename projects or stuff like that.
Could anyone help me on this ?

Thank you so much :slight_smile:

It could be your anti-virus denying access.
Whitelist Scrivener in whatever your AV’s options/settings are. (?)
(For example: AVG will list it as excluded from ransomware protection.)


That was exactly it ! Thank you very much for suggesting it.


1 Like

After many months with no troubles, now Scrivener cannot save any of my project documents. When I work on my project I get the following message:

— Project writer
The following errors occurred while saving your project.
Could not save project document “[INSERT WHICHEVER DOC NAME I’M IN]”
Failed saving text for document with id:{INSERT DOC ID STRING}
Error "Could not rename project rtf to .old rtf file name
To avoid losing your latest changes, make sure you have enough space and write access on your storage device.
You can create a copy of your project into another location using the File >Save As
You might also try to compile and save to RTF or Doc format to avoid losing your latest changes. —

I could save elsewhere, but this doesn’t solve the Scrivener saving issue. I know I have enough storage on my device but I don’t know anything about “write access.” Perhaps I need to edit properties of a file? but I am clueless in this area. Any suggestions (and hand holding!) appreciated.

“Write access” means Scrivener (or any other software) has the ability to create, update, rename, or copy a file. The most common cause of write access being denied is anti-virus software. Windows comes with Windows Defender as the default anti-virus software, so if that is what you are using, here’s how to tell it to leave your Scrivener project folder alone:

  1. Go to Windows Settings via the Start button and select “Update & Security.”
  2. Select “Windows Security”
  3. Click “Virus & threat protection”
  4. Scroll the window until you see “Exclusions” then click “Add or remove exclusions”
  5. Click the “Add an exclusion” button and add the folder of your Scrivener project(s)

If you are not using Windows Defender, your anti-virus software has a similar area for adding exclusions.

1 Like

Yep, that was it! Thank you! Drama solved.