Saving Collections as Binder Folders

I am doing something wrong here and I can’t work out what. I have a a few thousand older notes in a Scrivener document that I am trying to sort into named folders:

  • I do a search
  • I save the search as a collection
  • I reveal the collection in the binder (and see highlighted notes)
  • I make a ‘New Folder from Selection’
    Bingo - but only 4 times out of 7 attempts so far. Three times, so far, I have done exactly the same initial moves, but when I get to the final ‘New Folder’ command it is greyed-out in the menu.

As this is an incredibly useful way of beginning to sort a complete chaos, it is also incredibly valuable. But now I’m stuck: what might I be doing wrong, when I seem to be doing exactly the same moves in unsuccessful as well as successful attempts?


Strangely it works fine for me. I have tried it three times with three successes.

But do you really want to do this work to put so many documents into new folders?

Why don’t you just save the collections? These are also “folders” only virtual ones.

Thanks - it worked for me the first 4 times too - and randomly since then.

The sorting is the first step of quite a few others downstream (and in other docs/apps as well) so the way I have chosen to work with Folders are much the better option.

Just to leave no stone unturned, make sure the revealed docs are actually selected in the Binder: Select them.

Thanks - they are highlighted in the binder each time, so I assume that indicates selected (of course, if I click on any individual binder item I lose the multiple selection from the Revel in Binder move).

  1. I understand. It seems to me worthwhile (at least diagnostically) to try manually selecting the docs in the collection to see if that made the New Folder from Selection accessible.

  2. Another diagnostic thought: where does the new folder get created and what determines its location? If, for example, it is created in the location of the last Binder position and that happens to be the Draft folder, then a Collection that includes things other than text docs could not be placed there. This might be grounds for disabling the new folder option.

1 Like

Thanks again - interesting suggestion- some of these notes might just contain a pdf or two. I’ll certainly check.

Much appreciated gR - you’ve identified the issue - the Search Project scope defaults to All and so each of the problem cases was when the collection included a pdf from the Research Folder.

I now restrict the search scope and the problem is solved.

Thanks again.