Sb2 : Feature : minor : Inspector doesn't follow split close

Under a specific sequence of events, the Inspector will lose track of the document you are editing.

  1. With all splits disable, make certain that the editing focus has been activated in the editor view by typing or moving the cursor.
  2. Activate a split (it does not matter which kind)
  3. Change the current document via some means such as selection in the Binder or navigation of history. Again, make sure editing focus in in the split. The Inspector should change at this point (if it has not already) to reflect the details for the second document.
  4. Destroy the split with keyboard or buttons.

At this point, editing focus should return to the base document, but the Inspector will now state the message that it does when nothing is selected in the Binder. It does not matter if you move arrows or type in the editor, it will remain confused until you do something to re-select the document. Binder click, history navigation, Go To, et cetera.

Expected behaviour would be for the Inspector to keep track of the change, and switch back to the base document.

Hmm… I’ve tested this. What happens is that if the focus is in the split that is collapsed, then there is no focus so the inspector shows “no selection” or whatever. As soon as you click in the other split view, the inspector updates as expected. I’m not so sure this is a bug… :slight_smile:

That would be true if focus was nowhere, but actually it is established in the remaining split. You can begin typing immediately. If nothing was selected, then I would agree. All ordinary non-Binder methods of selection do not re-select in Inspector, as they do consistently in other conditions. In other words, clicking in the view to re-focus as you stated, does nothing for me. Perhaps it got “accidentally” fixed in b3?

Huh. I can’t start typing - I just get a beep (which is how it is supposed to be) - following your instructions, there is no focus.

Very weird, I can replicate it every time. I tried it on a fresh file just to verify. Just to narrow things down, here is an exact sequence that reproduces it for me. If that doesn’t work, I will send you my preferences file.

Setup: At least two documents (titled “A” and “B”); load A and then load B so as to have something in the history. With the cursor in the editor, press Cmd-Opt-Shift-A. Cmd-Opt-Shift-I to move to the alternate split. Cmd-[ to go back. Document “A” should now be visible, and the Inspector should be matched. Cmd-Opt-Shift-N to close the split. Inspector should be offline now, but the cursor should still be visible and ready to type in document “B”.

Okay, thanks, that did indeed replicate the issue. Will look into it. :slight_smile: