Scapple 1.3.2(281) become very slow/laggy in mac

Hi, long time user, first time contact.
I’m using scapple 1.3.2 to do some ming mapping about a TV drama I’m currently writing.
Now the notes hits 234 and it is becoming very laggy when I type in words, first I thought it is the Chinese IME I’m using that cause the problem, but it’s not,
When I type in English, the problem are the same.
When I quickly type a word, it always takes about 1sec for every single letter to show on the screen, it is becoming very disturbing for me.
My Mac is a 2013 macbook air 11’ i5 with 4GB of RAM, Mojave 10.14.3.
And I tried reboot, and create new file, when the note is fewer, there was no problem, I don’t know how many notes will trigger the problem.
All my notes are in Chinese character , all 234 notes counts about 2000 characters.and the over all dragging around seems smooth, just the typing is laggy, very.
Is it the computer just too weak for this job or it’s about the software? I also use a mac pro 4.1, not seeing the problem, but the file also contains alot less notes.
Plz reply, much appreciated.

Same thing here. Greatly annoying, but more troubling that no reply from support.
One of the things that’s kept me so loyal to the products has been the great support. I hope we hear something quickly about this. It’s blowing my productivity.

Lit & Lat has an actual Technical Support ticket system, so if you are not getting the help you need from someone here on the user forums, I suggest you open a ticket with Lit & Lat – the form for which can be found on their Support page.

Or more particularly, the form is here:


P.S. Nickskywalker, if you open a copy of that very Scapple file on your Mac Pro is editing laggy even there?

gr: You are right about the ticket system, though I too prefer the forums, as other members get the chance to chime in. In this particular case, it’s me, who takes this opportunity.
I have a large Scapple Map, which I can’t share unfortunately, that slows both, 2017 iMac as well as 2016 Macbook Retina down to being unusable until force quitting Scapple. This definitaly didn’t happen before that most recent update (Months ago).
I tried both, duplicating the file as well as copying the whole content to a new blank Scapple Map. I even pulled it out of dropbox to see if that was the cause. Didn’t help either.

In ALL cases the file works fine and fluid for about the first five to 10 seconds, before slowing down. (Memory Issue?)

Would be cool if either Keith could check what happend to the recent Version or let me revert to the version before, to see if that helps for the time being.

Thx a lot!!

Good News!!
Just downloaded the Version before (1.3.1) from here: … s?os=macOS which resolved the slow down issue for me!! Anyone else want to give that a try?

Now bad news. Upgraded to 1.3.3 and Scapple is obesely slow. What’s happened to the LL quality? I’m appalled that this has gone on so long without correction.
Scapple has been my go-to tool of choice since if first came out. If there’s no fix soon, I’m swearing off this software and, yes, you can expect I’ll be wanting a refund for this defective product.

Could you please verify if Scapple slows down at every zoom factor? For me everything works fine as long as I don’t zoom in. (Which isn’t any solution at all but may be a hint for L&L). Once I zoom in Scapple slows down, as soon as I zoom out everything goes back to normal.
Also: Does it depend on how big your file is? (Not necessarily in file size but how many notes you have taken?)

Yes, It slows down no matter the zoom rate.
Here’s the interesting thing. The slow down only happens after the first line of text. When the program auto returns to the second line it slows waaaaaaay down. When I start a new note, if I stretch the note box very wide i can type with no slow down, but the moment I’m at the second line of text, BAM Slows down. This shows there’s an error in LL’s programming. That they haven’t identified and fixed this says some pretty poor things about their software quality.

This is also raising red flags about Scrivener. If LL is content to let this kind of flaw exist in Scappel, it won’t be long before we see uncorrected flaws appear in Scrivener.
I think it’s honestly time to shop for a different writing program now. Scappel is already hurting my productivity.

Three things:

  1. It’s interesting that it does slow down for you even if you completely zoomed out -doesn’t for me. I tried what you said and converted all my notes to single line notes. - Makes no difference for me.
  2. I submitted a support Ticket. L&L are aware of this and they were finally able to reproduce the lag after more info was provided. They are working to find the cause now, but that may take some time as they also got other things to do, which leads me to the next point.
  3. I do understand that you need Scapple working. I also do understand that the current situation is not very satisfying. However I don’t agree with what you said in regards of L&Ls software quality. Given that bugs appear in each and every Software I can only praise L&Ls behavior over the last years. They were not only hunting down and fixing bugs with different initiatives but also didn’t release an update until it was ready to ship. One can easily name many software companies that release software and updates no matter if they are ready. In our specific case I believe that the situation is quite different as most users don’t seem to have as many notes on their boards, didn’t notice any lag or didn’t post about them. This makes it hard to track any issue. If only very few people (we are only 3 until today in this thread) are disclosing an issue it may not get the highest priority as opposed to other things. Especially over the last months, as L&L had to implement the change from eSellerate to Paddle and make it work as flawless as possible. This has taken number one priority for a reason. I do believe that everything will get back to normal now that the transition was made.

Having this issue too. Happens once I’m on the second or greater line of a bubble. Super annoying. Will not be able to continue using this software if they can’t find a fix for this.

I am also having the issue in Scapple 1.3.3 (v404).

Has anyone found a solution yet?

Having this issue too.

Same in here, I’m using the 30-day trial version on Windows and I really loved the software. But sadly when it expires I will not buy it because I find it extremely slow and painful to work with. It slows my workflow too much. And the problem it’s really the software because I have a very good computer. Shame

As this is the Mac Scapple forum and you have been using the Windows version …