Scapple 1.40.2 - Japanese text - note formatting always reverts

Hi there, since updating to 1.40.2, whenever I apply any formatting (such as bold, strikethrough) to Japanese text within my notes, as soon as I click out of the note, the formatting reverts back to being unformatted.

I’ve tried using keyboard shortcuts, the Format > Menu option and Control clicking the text. All have the same result.

I am using the macOS App Store version. macOS Ventura 13.0.

Thank you,

1 Like

Have you tried a few different fonts yet? I noticed that you just updated your operating system, which is a much larger change, and could likely impact fonts.

But you could verify if 1.4.2 is the culprit very simply, by downloading the previous version, and seeing if that works differently.

Hello @AmberV , Thank you, I downloaded 1.4.1 and confirm I don’t have the issue. So it seems 1.4.2 is the culprit.

I wanted to add that if you apply formatting to the entire block (without highlighting specific words prior to applying Bold, etc.) then it is fine. The issue occurs when highlighting specific words/lines.

Thank you for the update! We’ll look into it then, and see if there is something that got messed up with multi-byte fonts.

As a further wrinkle, I confirm this for Chinese, using the default equivalent for Helvetica, PingFang SC but only for Bold. Chinese fonts don’t have italic variants, but strikethrough and underline are both retained when exiting the note and re-opening it for editing.

Hope that helps.


1 Like