Scapple "invisible" to drag'n'drop

Occasionally, when first launched, Scapple is “invisible” to drag and drop. That is, if I drag an image onto Scapple, I don’t get the the little green “+” symbol on the cursor and, when I drop the image, it goes straight “through” Scapple to the desktop (creating the effect of the file vanishing because it can’t be seen behind Scapple). I wonder if this is the cause of the problem reported here?

I can’t reliably replicate the problem, but it has happened twice today, both times when Scapple was first started. However, if I close and relaunch Scapple immediately it doesn’t recur.

I’ve searched the console and only two lines seem to relate to Scapple:

30/06/13 9:16:15.843 PM WindowServer[171]: CGXDisableUpdate: UI updates were forcibly disabled by application "Scapple" for over 1.00 seconds. Server has re-enabled them. 30/06/13 9:16:16.631 PM WindowServer[171]: reenable_update_for_connection: UI updates were finally reenabled by application "Scapple" after 1.79 seconds (server forcibly re-enabled them after 1.00 seconds)
The times seem about right, but I didn’t think to check the clock when it happened, so can’t be sure.

Are you using the Mac App Store version or the regular version? I’m wondering if it’s a sandboxing issue.
All the best,

Regular version.

When this happens, is Scapple’s menu bar visible at the top of the screen, and is it dark to indicate that it has the focus? It may be that another application has the focus or that the inspector panel has the focus.

I think Scapple had focus, but I can’t be sure since I can’t reliably replicate. I didn’t have the inspector panel open. The only other thing I can say with confidence is that it happened twice on the same day when I testing drag’n’drop of different file types. Both times it was the first file I tried, both times it was a jpeg. The same jpeg normally works fine (I’m keeping it on my desktop and using for all testing). Every time I open Scapple, I test again, but since I posted above I haven’t been able to replicate (with focus on any of Scapple, Inspector, Safari, Finder, and various other apps).

I’ll keep trying to make it happen, maybe the person who posted in the other thread can contribute some detail.

Okay, let me know. The thing is that most of this stuff is handled by OS X. The Scapple view just registers for particular drag types, and then OS X tells it when there is a drop to handle. Next time it happens, also check to see if you can drag around in the application, because it registers for internal and external drops at the same time.

Thanks and all the best,

Just so you know, I’ve never come across this behaviour with anything else. In fact I probably wouldn’t have thought anything of it, ascribing it to user error, if it had only happened once. But then I saw the post in the other thread, then it happened again. The second time I did check more thoroughly, testing it to be sure that there really was a problem with the drag and drop process and not just something I messed up. So I am absolutely confident it happened, and cannot think of any other app in which it this has occurred (although, outside of Keynote and Mail, I don’t drag files into many apps). Not to say it’s not an OS X issue, just that it seems to be triggered by Scapple under some arcane circumstances.

I’ll keep trying to replicate and as soon as I am able to, will post or email whatever I find.

I’m not saying it didn’t happen or that there couldn’t be a bug there, only that I can’t reproduce it and I can’t think what would cause it given how drag and drop works, so I’ll need to see it for myself to work it out.
All the best,

Didn’t mean to imply that you you were questioning me. Sorry. :blush:
Every time I launch Scapple I test it so I have something useful to add, but so far nothing. And that’s bugging me because I had a system reset in between the two previous times. I’ll keep testing and report if I ever have anything of value.

Welcome to my world: “Why can’t I reproduce this, argh!” :slight_smile:

I have the same problem and it’s repeatable. I got one Scapple note dragged into Scrivener’s free-form corkboard, but no green “+” on the others. I quit both Scrivener & Scapple, reopened both, got one note dragged into Scrivener, then none. Now I can’t even get one note across. :question:

Scrivener: (regular version)
Scapple: 1.20.1 (Apple Store version)
macOS: Sierra 10.12.5


Are you dragging notes from a stack by chance, and if so, any of the notes not involving the first note in the stack? I ran a quick test by creating three notes in a stack and dragged the third note into a freeform corkboard: nothing imported and I got a failed drag. I then selected the latter two notes in the stack and got the same result when dragging them over. Finally I selected all three notes and they all three imported as cards.

So long as the first note in the stack was selected (using Cmd-click to select the first and third note for example), they could be imported, and so long as a note wasn’t involved in any stacks it would be imported (one all by itself).

If you aren’t using stacks, can you think of any other contextual conditions that might be involved? Are the notes on or off a background shape, are they linked, etc.

I use Cmd-Enter to create a new note below the previous one. I forgot that creates a stack. :unamused: Yes, that worked. And when I created another note not in the stack (double-click outside stack), it drug over without issue.

Thanks so much AmberV. :smiley:

p.s. For anyone not familiar with this process, I usually keep my corkboard in the “Keep cards arranged in binder order on a grid,” so I have to remember to switch to “Freeform” on the corkboard before dragging from Scapple.