Scapple says file is locked, but finder says it isn't

I opened and modified (on a Mac), an old Scapple document from last year that I had created in Windows. I then started getting popups saying “The document could not be autosaved. You don’t have permission.”

When I try to save the document, I get a popup saying it can’t be done because “The file is locked”.

However, according to the file info window in Finder, the file isn’t locked. And I have verified that my username has read and write permissions.

I have tried editing the XML in Brackets (text editor) and saving the file, and this I was able to do with no problem. When I then opened the file in Scapple, the change that i had made to the XML was visible in the displayed document.

I tried creating another Scapple document and saving it to the same folder, and this I was able to do without problem.

I can see no problem with the UNIX permissions and ownership of the file. They are:
-rwxr-xr-x@ 1 robert staff
(I am robert)
The permissions of the test file are:
-rw-r–r–@ 1 robert staff

The only difference I can see is that, in the info window in Finder, there are also permissions for through to for the problem file, which are not there for the test file.

One final piece of information is that the folder is synced to iDrive cloud storage, which can behave strangely sometimes.

Why can’t I save my file?

Dear Krispin’,

I’m not the expert, but I’d guess it is because your file is being stored in the cloud (remote only) and Scapple is operating on the assumption that the file is where the directory says it is. At least this would be the likely answer if we were talking about a Scrivener project.


Thanks for the reply.

The file is definitely stored on the local file system.

However, I discovered that the test Scapple document that I created today in the same folder got deleted twice without me choosing to delete it. This makes me think that the issue is with iDrive, or perhaps even with MacOS, and I am in contact with iDrive support to find out what is going on. If I don’t make another comment on this thread in the next two or three weeks, assume that the problem lies elsewhere than Scapple.