Scene Heading and Action are split

I really don’t know how best to title the topic. Scene Heading stays on current page, but when I write the action underneath and it doesn’t fit, it starts on another page or splits and leaves the scene heading on the previous page, splitting the scene heading and action. How do I ‘cheat’ that, or keep the two together as they should be. I remember I had this same problem years ago and was able to easily fix in the options, but can’t find it in the update. Please help… Many thanks in advance…

The “Page Break Before” option was in the options in the previous version.
In 3.0 this is solved by Separators in the Compile Format.

Assuming this happens when compiling:

  1. In the Compile Overview window check the name of the Section Type in the right-most column for your titles and scenes.
  2. Click the Assign Section Layouts button and check which Section Layouts are assigned to the Section Types you just learned.
  3. Double-click the name of the Format you use in the left column to open the Compile Format Designer.
  4. Click the Separators tab on the left and your Section Layout on the right.
  5. Update the Separator before and Separator between sections from Page Break to Single Return or Empty Line.
  6. Save and Compile you titles and your scenes on the same page.

When this happens when your Editing, I have no clue how to solve your issue.


Seems unnecessarily complex just for wanting two elements that should belong together, be naturally together. Why must we force/edit them to come together? Are there screenwriting rules that leave a Scene Heading stand alone apart from the following Action? Just wondering… I haven’t printed the script as of yet, as this happens only as I write. Newer versions are sometimes a drag. Thank you for this info. I appreciate it…

On the other hand - I have no clue. Compile Overview? (Sorry, newb on this) I’ve never had to use ‘Compile’ before as I just use this to type out, not print. I’m noticing throughout my script - I can’t get that ‘page break before’ as you say. It’s happening now with all my action scenes too - where half the sentence stays on the bottom of one page and the rest (one sentence only) carry over to the next. Must I go through these steps to adjust and have a normal, functioning script according to Hollywood or basic standards? Are we talking about the same thing… Not sure… ? Thanks.

So, you’re writing a script. You haven’t printed it, nor generated an output document before.
In your script headings and scenes don’t stay together.
Now we’ re on the same page.

If you select to view Special Characters, do a lot of paragraph characters show up?
Do you have a Style with lots of white space after the Titles or before the Scenes?
Is the option to Format > Paragraph > Keep with next checked or unchecked?
Does Script Mode have a fixed page size, contrary to other writing modes in Scrivener, like writing a novel?
Are your Scene Headings Binder Titles or do you type them above the scene yourself?

Trying to find an explanation for this issue, but I know too little about scriptwriting in Scrivener. Maybe other forum members can jump in and explain why this is happening.

Thank you. Yeah… it’s very unfortunate. Sentences are not made to be split in screenwriting and carried over to the next page - a process easily fixed in old Scrivener but made exceedingly difficult with the new - at least, it seems so far. It should just be default, but it is not. I’m missing something or the program is? Sure could use some help… Many thanks kind sir…