Screenplay mode and Avid ScriptSync

Hi there.

My day job is film editor, but I also do some writing as a hobby. I love Scrivener. I’ve been using Script mode for awhile and I really like it.

There is a great new feature in Avid Media Composer called ScriptSync. It allows film editors to import script pages into Avid, and it uses voice recognition to connect the written lines of dialogue with the exact piece of footage (or voiceover recording) that contains each line. It’s pretty amazing.

If you are interested, there is more information about ScriptSync here:

filmmakermagazine.com/fall20 … screen.php

Here is my problem: ScriptSync expects the script in plain text format, with indentations. (It uses the indentations to separate the dialogue from the scene headings, action, etc.)

When I export from Scrivener, I lose the indentations.

Is there any way to fix this, or any workarounds you can think of? Thanks.

–Ed Fuller

Hi Ed, I’m not expert with this - I’ve never used ScriptSync myself - but I’ve read a little about it and I edited a couple of things for TV in my previous life. I’m now a writer-producer and I work with Scrivener every day and Final Draft a good deal. So I might be talking rubbish or I might not. Disclaimer over.

As I understood it the Avid ScriptSync format requires scene numbers or at least page numbers to work properly. If this is the case then your best bet is to export to Final Draft (add scene numbers if necessary) then ‘save as’ from there. Even if Avid would accept these numbers (from Scrivener) as an added new paragraph, you’d still have to enter them manually which I suspect would be fairly onerous.

If I’m completely wrong about the scene / page numbers thing, then we’re back to your original question, and then yes - you should be able to set up Scrivener’s Compile Draft settings to precisely match the same indentations that you would see in a .txt exported from Final Draft.

Personally I’m slightly terrified of the text formatting options in Compile Draft, so I’ll leave it for more advanced souls to pick up if you need further help there. Sorry not to be more help. Please do post back on here with your findings.

best, Robin

Hi edfuller,

I just EXPORTed this example as text. EXPORT>FILES>EXPORT MAIN TEXT AS:>Plain Text (TXT)

It seems properly indented to me.

Did you try this approach?

It might work.

:slight_smile:

Hm. Nope. I tried that and it doesn’t work for me.

If I type in regular mode and use tab stops, the indentation carries along with the export.

If I type in script mode and export, I lose the indentation.

Did you type the example above in script mode? If so, I wonder what you are doing that is different from what I am doing.

(Line numbers are not needed, BTW)

hi Ed,

This is not going to please you, but it might point you in the right direction.

I went away and created three Scrivener versions of three different scripts.

  1. Script generated in Final Draft 7- exported to Scrivener as RTF.

  2. Script generated in Movie Magic Screenwriter Pro 6 - exported to Scrivener as RTF.

  3. Script entirely generated within Scrivener in TEXT > SCRIPTWRITING > SCRIPT MODE.

All were then EXPORT-ed as TEXT.

All gave me proper script layout in TXT files.

I then reflected on other possible issues raised by your problem of zero indented scripts.

  1. Is it possible you may have set some layout preferences to left align?

Check the preferences in TEXT EDIT.
Format should probably be set to Rich text - a paradox. Try it both ways - Rich and plain. And tick Wrap to Page.

You could also try the Open and Save preferences in TEXT EDIT. Tick Add ‘.txt’ extension and also try 'ignore rich text commands in RTF files and preserve white space.

What I’m driving at is that I don’t think the problem is Scrivener, I’m guessing it is the preference settings in the text application you export the Scrivener file to.

  1. Try EXPORT-ing the script as a PDF from Scrivener. That could indicate if you have a strange alignment problem. In theory the pdf should look exactly as it would if it was printed out.

  2. Try EXPORT-ing the Scrivener script as an RTF then when it is in TEXT EDIT you can just go to FORMAT in the menu bar and ask TEXT EDIT to MAKE PLAIN TEXT.

All is not lost.

:frowning:

Hi,

Sorry for my late reply, but I’ve only just had time to look into this.

I think Lord Lightning must be exporting as plain text from another program - perhaps Final Draft? The script format in Scrivener uses rich text-based features such as first line indent and so forth to format the text. When converted to plain text, all this is lost.

Final Draft puts a lot of spaces in there if you export as text only with indentations (or whatever it’s called).

Unfortunately, because there is no demo of Avid’s app, it is impossible for me to test this to see what would be required. I could set it up so that tabs were inserted, but this would only work for the first line of each paragraph where there was a head indent, and I’m not sure this would work with Avid. In other words, it would be very difficult for me to work this out “blind” as it were…

Best,
Keith

Hi Keith,

As I said in my post I exported FROM FD and MMSCW6 as RTF - imported to Scrivener as RTF. Then exported as .txt, which Avid requires (ASCII text - LINE BREAKS option ON). This sequence worked for me.

Avid allows you to skip lines that only contain Capital letters - so Character names aren’t seen by Avid as dialogue. It also allows you to skip text in parentheses() or brackets[] - so ‘wrylies’ are not counted as dialogue. It also allows you to skip lines indented less than dialogue - so that after letting Avid see a sample dialogue indented line (Avid just counts indented characters) it knows that Action is not dialogue. Avid also lets you skip text before a colon( : ) - so it knows that time code numbers are not dialogue.

So Avid’s Script sync is entirely dependent on the consistent layout of the ASCII text (.txt).

My experience is that Avid reads that Scrivener .txt perfectly OK.

Made me think that maybe an intermediate app. such as Text Edit may have its preferences set to something that alters the spaces (indents), such as left align. It’s just a deduction from the small amount of detailed info in the original post to this thread.

Don’t know if that helps - hope it fills in another bit of the deductive jigsaw puzzle for you. Have to start calling you Sherlock Blount if you figure this one out.

It is clear that you have already made this link - but any interested lurker who can help here it is:

avid.com/products/media-comp … ptsync.asp

:slight_smile:

Hi LL,

Well, I just exported a script from FD as RTF, imported into Scriv and exported it again, and… No indentations. Which is what I would expect, because there is no real whitespace in the file, only indents, which plain text doesn’t understand… So I’m not quite sure what extra steps you are taking, but I wouldn’t expect Scrivener to be able to get this sort of output.

Best,
Keith

Hi Keith.

The output of Final Draft using “Save As: Text Only with Layout” works perfectly with Avid ScriptSync. So if you are able to reproduce that format it would solve my problem.

As it is, my workflow is to export from Scrivener to text, import to Final Draft, check the formatting, and re-export to text again.

Thanks again for Scrivener. It’s my favorite Mac application right now. --Ed.