Screenplay synced to iOS cannot format

I synced a screenplay to my iPad and it opens fine but not in screenwriting mode. More like just RTF. Is there some setting I can apply or should I delete and retry?

I started a new project on my iPad and this works perfectly with all the options of Action, Character, Parenthesis, etc. Thanks, amazing app, Rynbow

I managed to make the tab-formatting work to go from Action to Character etc., but the font on the iPad is a sans serif. Changing the font in the “compile” options works for the pdf but not onscreen for working on the iPad. When I add new text this is formatted in Courier as expected.

Now I have a document partly in Sans serif and partly in Courier. I can live with that but if there is a way to have everything in Courier, I’d like to know. Unfortunately when I make edits on my iPad and sync to my macBook the newly synced sections now show up on my macBook in Helvetica : /

Have you updated the Mac version of Scrivener?
Are you using Open and Save on both Mac and iPad and no other means of “importing” stuff?

Thanks. I am up to date. However, I cannot find a ‘save’ option on the iPad. I just open and for the rest I use ‘sync’. From time to time I get a conflicted copy which I am not sure how to deal with.

My main problem is a matter of fonts. On my Macbook, I work in Courier Final Draft. On my iPad everything opens in Helvetica. This is more of an inconvenience than anything else, but I would feel more secure in Courier.

(When I create a new document on my iPad, this uses Courier Prime, and on syncing to my Macbook this document opens in Courier Prime as well.)

I may need more advice than I am aware of : )