Script compiling substitutes characters with random symbols.

Bug description:
When I compile in “Script or Screenplay” format, more often than not, some lines of my text get substituted with random symbols (check the image). Recompiling a bunch of times more, without changing anything, usually solves the problem. I’ve noticed this first after 3.0, but there’s no way to tell if it was introduced with that version.

More details:

  • The same happened to a normal file text (not in script formatting) that I compiled together with my script bit and that was placed at the end of it. The whole (one page) bit of text was ruined.

Hi, could it be possible to receive some kind of update on this? Is it a known issue, is there a fix? Or perhaps I’m posting in the wrong section? If so I apologize and if you could be so gentle to point me in the right direction, it’d be appreciated.

The document I need to export today keeps converting the same bit of text into symbols. I’ve tried exporting around 10 times. If I remove the bit of text (action in screenplay format) all is normal. I reintroduce the text and the problem represents itself.

I produce 3+ documents a week through Scrivener and I currently have to manually recheck every last line of them to make sure that they’re not corrupted.

Thank you-

Check out this thread, it looks like it might be the same issue:

Hey Glaconius,

I’m curious, do you have this issue?

Yes, I do.

Saw this just now, I’ve followed the instruction, but as the problem doesn’t always happen I still have no way to check if it’s solved.

Thank you anyway, hope this works.