Scriptwriting mode fn+s,a,c,d, etc formatting shortcut keys have stopped working

For six months I’ve been working on a screenplay and have used the formatting shortcuts; fn+s (Scene Heading), fn+a (Action), etc. I recently upgraded to macOS Monterey (12.1) opened Scrivener, went back to work on my screenplay and found the fn+KEYS no longer work.

Any suggestions?

Apple has unfortunately taken over all of the Fn key shortcuts, best we can tell. It’s something we have on the list to look into getting around, but it is likely this modifier key is now meant to be off-limits to software developers, going forward.

There are of course other ways to access elements directly, such as the Opt-Cmd-numkeys along the top of the keyboard, and Shift-Cmd-Y + a letter key corresponding to what you’re used to with the old Fn key system.

That’s a big bummer. But thanks for the help.

I recommend using Keyboard Maestro to fix this. You just have to get used to typing control+s for Scene heading instead of fn+s. Once you get used to automating using KM, I bet you’ll find a bunch of things you’ll want to add to make Scrivener run more smoothly for you.


Scriptwritting shortcuts suddenly sttoped working after I updated my os to Sodoma. I’ve also updated Scrivenner to 3.3.6., but nothing happened. The rest of the shortcuts in Scrivenner seem to work well, as they were before the update.

Any ideas on how to fix this?

Thank you!!

That was the wrong one, you need macOS Gomorra.

Just kidding. This may sound like a stupid question, but did you accidentally turn off Scriptwriting mode (e.g. hitting 8)?

oops, your right about sodo/no/ma :sweat_smile:

Yes, I’m deffinetly in scriptwriting mode, which is the one I use 75% of the time.

I checked with a friend who’s also a screenwriter and strangely, her shortcuts for Sequence, Character, Dialog, etc… are “alt+cmd+number” type of shortcuts. Whereas, in my case, they continue to be the same “S”, “C”, “D” … that they used to be.

Before the update, I typed fn+the shortcut and it worked fine. Now, depending on the shortcut, whether it does nothing, or it activates some other function, as for instance Dictation.

I tried to manually change the shortcuts in the Script Settings menu, but it does not allow me to use modifier keys…

Any clue of what may be happening?


I had no idea this was actually working at some point in the past and trying to process what the FN key could possibly do in this scenario. Thanks for making me feel younger.