Scriptwriting: No new line when switching to different element?

Is there a way to keep the cursor on the same line when switching between script elements?

I am writing a 10-minute play for a festival, and the theatre’s style sheet shows that they want Stage Directions to be in-line with dialogue and italicized, rather than placed on separate lines. I’m trying to create a script format in Script Settings to accomplish that, but when I’m in a dialogue line in the editor and I press Tab, the cursor advances to the next line.

Is there a way to configure the Tabbing relationship between Dialogue and Stage Directions such that pressing Tab will still switch to the designated element but keep the cursor on the same line?

Have you visited the settings at Format > Script > Script Settings…?

Yes. Here are the settings that I’ve configured for the Dialogue element:


But I don’t see any way to configure the new line behavior for “Tabbing after typing”.

Have you tried changing the “space before” in Script Seetings to zero? That might keep it on the same line.

Yup, “Space Before” already was set to 0.00. No joy.

I reckon that I’ll just deal with it in the flow of writing, then go back and move the Stage Directions as needed.

Thanks for replying!