Scriptwriting - word drag and drop problem

Since upgrading to v2, I have a persistent problem in scriptwriting mode. Every time I move a word from one line to another, the word’s following space seems to pull from nowhere a Helvetica 12 point font - with a consequent change in line-spacing. (The document is formatted to a version of Courier, 11 point.) I then have to either select the paragraph and re-set it to the correct scriptwriting element, or make sure I delete this moved word’s following space, by eating into the previous or following word.

I’ve copied and pasted the whole (using paste and match style) into a new document and then gone through to re-format all elements. It still persists.

It’s very annoying, so any ideas/assistance appreciated.

Thank you.

I can’t reproduce this. Could you please provide a set of instructions that will allow me to see the issue for myself?


I’ll email sample. Thanks.

I’ve emailed a sample but forgot to include its font (I use Adobe’s Courier STD - slightly better than Courier/Courier New for Full Screen use). I don’t know whether you’ll need it or not.

My setting is a play format (11 pt font). If I double click on a word in the dialogue part and drag, say, to the line above you can see something is amiss because the line spacing then increases slightly. If I type into a space after the space of the word I’ve just moved (if you follow me) the new typing’s font is now Helvetica 12 point. I can reset the scriptwriting element as many times as I like and the behaviour is still invariably the same. As I said I’ve even pasted text-only onto a new document and reset all the elements and it still does the same.

I’ve exported to Nisus and TextEdit and can’t reproduce the behaviour.


When you export to TextEdit or Nisus, is the font the same in the resulting document? What happens if you test with a different font? It could well be a font issue, but if that were the case I’d expect to see the same behaviour in TextEdit; on the other hand, I can’t think of anything that would cause any different behaviour in Scrivener. What about if you use the font in a document that is not in scriptwriting mode? Does the same thing happen, or does it only happen in scriptwriting mode?

Thanks for sending the sample - we’re all catching up on e-mail that was sent over the Christmas period so it may be a day or two before it gets to me, but I’ll take a look as soon as it does.


Hello Keith
Basically yes to all your questions. Same font on export. Still happens not in scriptwriting, and still happens if I change font.
Very odd. It can be easily seen if the font window is kept open. Drag and drop a word, go into the following space and invariably font window shows Helvetica 12 pt.
I suppose the next thing will be to ditch all my preferences and start all over again. Do you think?
Thanks for getting back.

Can anyone else replicate this?
Having looked into it, I get it each and every time - with new documents, brand new preferences, scriptwriting mode or general. In fact I can’t not get it.
Select a word. Drag it elsewhere. Open up font-window (cmd T). Put cursor in the word previous to the moved word. Font-window should highlight the correct font in use. Now, with one eye on font-window use arrow to move one character space at a time along and into the moved word, then through and into following word. At some point (either in the space before the moved word or the space after it) the font-window will jump to Helvetica 12pt for a single character space and then back to the correct font.
Would appreciate knowing if this is just me.
(It might be asked, so what? Trouble is, if you type in that space the font will be Helvetica; and if you use any other font size but 12pt for main font, it subtly jiggers about with line spacing.)
(Also TypeIt4Me’s update this week now has problems with Scrivener’s Full Screen - I have contacted their support. [Sigh] When it rains it pours.)
Thank you for your time.

Actually, Ioa - L&L’s support bod - has replicated something similar, but with cut and paste, and he gave me the instructions on how to see it. Yesterday I managed to reproduce it myself, which means I can now investigate, and so it is on the list for 2.0.3 for fixing. Hopefully now that I can reproduce it, it shouldn’t be too difficult to figure out what’s going on. I’ll try to remember to reply to this thread when I investigate it next week, to let you know when I fix it or find the cause.
All the best,

Okay, I’ve repeated it with drag and drop.

  1. Double click the word to select it. (I can only repeat this by double-clicking to select a single word; dragging the mouse or using shift and arrow keys to select the word otherwise doesn’t reproduce it nor does triple-clicking to select the paragraph.)

  2. Drag the word to another paragraph. The fonts of the selected word and paragraph dragging to don’t need to be the same, but shouldn’t be Helvetica. (Also it doesn’t really have to be another paragraph–even dragging the word over in the same line produces these results.)

Example: Dragging “purple” into the phrase “eat chocolates”

Results: If you drag “purple” so that the cursor is placed at the end of “eat” (no space between) a space gets added between “eat” and “purple” and that space is Helvetica 12pt. Typing after it (before the word “purple”) produces text in Helvetica.

If you drag “purple” so that the cursor is just before “chocolates” the space gets added between “purple” and “chocolate” and is Helvetica.

So a possible workaround in the meantime, T.P., unless you’re getting different results, might be to select the word by another method, if that’s not too obnoxious.

Yes, double-clicking in the word was the trigger in cut and paste too - I have no idea off the top of my head why that would be, but as I say, I’ll be investigating this next week.

The best work-around that I know of is to disable Smart Copy & Paste, actually. That’s the primary trigger, along with using double-click to select. With that feature turned off, you can continue using the editing features in a fashion you are accustomed to—you’ll just need to add spaces around pasted words here and there.

And just to clarify, Ioa’s solution is just a temporary one until I get this fixed (for 2.0.3 hopefully) - we’re not suggesting that you shouldn’t use smart copy and paste (which is very useful), just that there is clearly a bug here at the moment and turning off smart copy and paste provides a workaround until I’ve got to the bottom of it.

Okay, I’ve located the bug and fixed it for 2.0.3.