Scriv 3: Custom keyboard shortcuts not working

Upgrading to Scrivener 3 (under Mac OS 10.13.1) appeared to have broken my custom keyboard shortcuts, but after deleting them within System Preferences and recreating them, I can’t get them to work properly.

As far as I can tell, I’m creating them properly (no problems with other apps, for instance), but most do nothing, some do something strange and some won’t override Scriv’3’s built-in shortcuts. Assigning "Shift Command ]"to Increase Indents, for instance, instead right-aligns text, while “Shift Alt Cmd U” for Make Uppercase does nothing. These were my shortcuts in Scriv 2 and they worked fine…

What am I missing…?

I had similar problems while beta-testing, but then it was linked to changes in the wording of the commands. Changing the wording, usually solved the problem.

I don’t say that this has anything to do with your problems, but:

are you working in a non-English, translated, version?

do you use a non-English keyboard?

English version, English keyboard – and the shortcuts worked normally in v2…

Unless there are spaces or other non-visible characters at the end of menu commands, my shortcuts are correct – and these are new shortcuts, recreated after the existing ones stopped working post-upgrade (which I’m now guessing was the same problem faced here)

Any news? I would like to know if this problem is affecting more users before completely moving to S3.

Do you still by any chance have Scrivener 2 still running on your Mac? Is it possible that the system is getting confused and trying to apply the shortcuts to v. 2?


I was wondering that - Keyboard Maestro, for example, uses Apple’s internal identifier for programs, so when a program goes through a major update you need to reassign the menu shortcuts. This happened for me in changing from Scriv 2 to 3.

Perhaps something similar is happening here?

FWIW I right now had to change the text, because of translation, for some of the very shortcuts you mention (upper, lower and title case) with the shortcuts Shift-Ctrl-V, Shift-Ctrl-G and Shift-Ctrl-T, respectively (the same shortcuts I used in V.2 and in the English V.3 before translation). It works fine. Maybe because I don’t have V.2 on the computer, and haven’t had for a long time.

I don’t, but only because the new app replaced its .app file – all other related v2 files will still be in place. Interestingly, while I removed the old app and its shortcuts from Keyboard preferences and then added the new one, the new app still appears with the v2 app icon.

I would like to know if other users are able to reproduce the reported problem with keyboard shortcuts.

This is fixed, I think. I restarted in Safe mode, completely removed all trace of Scriv 2/3 (using TrashMe) and all keyboard shortcuts. Restarted in normal mode, reinstalled Scriv 3 and recreated the shortcuts (the correct app icon appears this time). All working as before.

So, it seems the upgrade is something of a rigmarole and it’s a good idea to note any existing custom keyboard shortcuts beforehand, so they can be recreated.

Incidentally. I installed Scriv 3 alongside Scriv 2 on another Mac – same problem. It seems the Keyboard app shortcuts preferences can’t distinguish between the two apps. Adding the Scriv 3 app separately here simply groups it with the existing Scriv 2 shortcuts – even though the two apps can be open at the same time.

So, I’m not sure any of this is Scriv’s fault – I suspect it’s a macOS issue. Might be worth noting in the manual, maybe?

Update: Just deleted Scriv 2 on Mac #2, leaving Scriv 3 in place and keyboard shortcuts work normally when recreated.

Thank you very much for your very useful feedback. I’ll move to S3.

No problem with custom keyboard shortcuts in my MacMini but my MacBook Pro doesn’t take my customized keyboard shortcuts at all and I have followed the same exact procedure, cleaning the previous S2 install. Even more strange: customized keyboard shortcuts work in my administrator account but not in my standard user account.
Any suggestion?

IIt’s necessary to erase Scrivener Preferences folder and to delete existing shortcuts (inherited from S2). Afterwards, it’s possible to customize shortcuts. Anyhow, it’s awkward.

I prevented this rather simply by renaming the old file to Scrivener, and renaming the new file to Scrivener before I opened Scrivener 3. It seems that MacOS rather stupidly goes by the app name rather than by the internal app identifier.

With this bit of prep, Scrivener 2 and Scrivener 3 shortcuts showed up completely separately in the Keyboard Shortcuts pane, and I recreated my old keyboard shortcuts without problems. Well, with few problems—I still had to contend with keyboard shortcuts that were already used in Scrivener 3 as well as re-worded menu items. But nothing like the problems reported in this thread.

Hope this helps.