Scriv 3 - Spell check

Ok so I’m obviously an idiot but I can’t work out how to get the spell check to actually function other than manually starting a spell check with that horrible box thing. Which I inexplicably hate.

In Scriv 2 it used to just put that wavy little red line under typo’s etc, I could choose to fix it right away or if I am on a roll I can ignore it and come back later since the visual marker makes it easy to spot. I checked the manual and I think I’ve got all the things selected in the preferences tab but obviously not since it isn’t working … what am I missing?

Help… someone…pretty please?.. its driving me nuts…

The option to check spelling while working is set per-project now, rather than globally, for more flexibility. For instance, you may want it on in a non-fiction project but off for your fantasy novel with all the made-up words. To toggle the setting, go to Edit > Spelling and Grammar > Check Spelling While Typing.

New projects will automatically have this on or off based on however you last set it in a project.

Thank you! Doesn’t really make sense to me that I can have everything checked in the global settings and it doesn’t work until I check it in general settings but hey, it works! Woohoo!

Oh and I write Fantasy, you are correct it does pick up all kinds of things that are intentional as well but I still prefer that to the crappy little spell checker box. Lol

Thanks for your help.