Scrivener 1.10 and LaunchBar 4.3.2

This isn’t necessarily a Scrivener bug, but probably worth noting (I’m also going to report it to Objective Development).

Scrivener hangs when I quit an app launched using LaunchBar. When Scrivener comes back to the front and I click in the main editor, the cursor stops blinking. If I type some text, it doesn’t appear until I click somewhere. The cursor still does not blink and if I click somewhere else on the screen, the text between the old and new positions is briefly selected.

The only way to get Scrivener back is to click on a menu. All the text in the editor is selected, but Scrivener unhangs. Until the next time I launch a program with LB and quit it.

The problem does not occur if I launch a program from the dock and quit it. Nor if I just switch back to Scrivener from another app. Nor if Scrivener doesn’t come to the front when I quit the other app. Nor if I quit an app launched before Scrivener. It only happens when I quit the app launched with LB while Scrivener is the active app.

I know. Stop using LaunchBar, you say. Okay. Maybe. Sure as hell not going to stop using Scrivener. Just thought I’d bring it up.

Have a nice day.

I also use Launchbar and can’t reproduce this–not that I’m denying your experience!

I’ve just done some more testing and it seems that it’s probably a LaunchBar bug, or possibly a cocoa editor one. The same thing happens with TextEdit, although not Mail.

I forgot to note that I am running Leopard on an early iMac G5. Not sure it’s in my profile.

The same here. No problems.

The fact that it is happening with TextEdit too makes it almost certainly either an OS X or LaunchBar bug, as both Scrivener and TextEdit use the same standard OS X text engine. I wonder if that is related. Mail no longer uses the standard text view that Scrivener and TextEdit use - it uses a web view instead, I believe, for editing text. It might be worth trying with Bean, or WriteRoom, or another app that also uses the standard text engine (MacJournal etc).
All the best,

Michael, can you name a specific program or two that you’ve launched using Launchbar which then causes the hang? I want to give this another try, out of curiosity and to see if I can help.

More testing.

It’s Typinator 2.0 that’s causing the problem.

Apologies all round to Keith, Norbert at Objective Development, and Apple.


A little more info. This issue doesn’t seem to be related to the cocoa text editor after all. Mail hangs if I quit a program launched with LaunchBar (while Typinator 2.0 is running) then click on a folder in the mailbox list. It unhangs when I click a menu. Although I haven’t tested it - I’m fooling with Spaces and Spotlight as a (poor) substitute for LaunchBar - Scrivener might also hang if you click in the binder.

I’ve reported the problem to Objective Development and Ergonis, both located in Austria, so maybe they talk.

FYI, Scrivener will hang if you click in the Binder list under the circumstances described above. It’s definitely a mouse click thing between Typinator and LaunchBar, although which program is causing the problem is completely beyond me. One final clue is that if LaunchBar is started after Typinator (not during login), the problem does NOT occur.

That’s it. No more. This is NOT a Scrivener issue, except insofar as that it affects Scrivener, Mail and who knows what else.

Cheers and happy Scrivening, y’all.

Weird, I cannot reproduce this, and I’m using Launchbar + Typinator 2 + Leopard.

I was going to drop this thing, since it isn’t a Scrivener issue, but…

At the request of Ergonis, the developer of Typinator, I performed some very specific tests. I disable all login apps, logged out, then logged in and started Typinator and LaunchBar from the dock. I then ran TextEdit, created a document, then, from TextEdit and using LaunchBar, started Safari. I then quit Safari, which brought me back to TextEdit. I then clicked the mouse button in the text. TextEdit hung - that is, the cursor stopped blinking and nothing happened when I tried typing some text. On the next mouse click, though, the text appeared, but the cursor didn’t resume blinking. The only way to get control back was to click on a menu item. Then everything’s okay. I repeated the procedure starting LB first, then Typinator. Same result.

The same thing happens in Scrivener’s main editor. Not in Mail’s, though. Or Pages. However, in both Scrivener and Mail, if the first thing you do after coming back to the program is click in the mailbox list or binder, the program hangs until you click a menu item.

For LaunchBar and Typinator lovers, Objective Development and Ergonis are both working on the problem. It’s not fatal, just a little unnerving. But, as I said, it’s not a Scrivener thing, so this is REALLY the last time I’m going to bring it up here.

It must be something else, because I am using the precise configuration you are; following your directions exactly; and have no problems with text entry areas. I even tried quitting the second application with Cmd-Q, and using LaunchBar’s facility for selecting a running app and quitting it from LaunchBar. Neither method caused the screen update bug you are describing. I’m using Typinator 2.0, LaunchBar 4.3.2, and Mac OS X 10.5.0.

How about language? English keyboard and localisation?

And it’s okay. Even though it has been established this is not a problem with Scrivener, this topic is more topical than half of the threads here going on about Vikings scourging the Spanish in their hard drives, and whether or not Trojan is a good proper noun for describing evil software!

but all that tripe does help keep the brain dead semi focussed :wink:

saw this earlier, and it realy cracked me up:


I just fell about at Borders

00100010 00101110 00101110 00101110 01101111 01100011 01110101 01101000 00100001 00100010


It was actually last Christmas; I think it was Borders; stood in front of a promo display of three or four tittles, when I noticed that on a cover of one, a joke book. I really did crack up. A woman who was stood next to me, gave me a dirty look and moved away

I bought the book.

Apparently, my binary/text converter, doesn’t belong in the same abysmal catagory as my language translation widget.


Language: English. Localization: Canada. Keyboard: Canadian. But it’s worth checking out with the US keyboard selected.

I can replicate the problem on my iBook G4 with a brand new erase and install of Leopard, absolutely clean.

But go figure. I just tried to replicate the problem on my G5, but couldn’t’. With Scrivener, iTunes and Safari running, I switched to Scrivener, launched the Dictionary with LaunchBar, quit it, which brought me back to Scrivener. When I clicked, Scrivener didn’t hang. Then I tried it again, and it did. Argh. Switched to the US keyboard driver (without logging out), but it didn’t make a difference.

Maybe OS X 10.5.1 will fix it. Or the next round of sunspot activity.

I had a binary relationship once. It was on again, off again.

too many comedians around this place! :wink: