Scrivener 1.2 - iOS 13 - Settings - Syncing & Sharing Crash


I just installed the Scrivener 1.2 on the new iOS 13 and if i go to Settings -> Scrivener -> Syncing & Sharing the Settings are crashing instantly.

I am using an iPhone XR

This is happening to me as well. Also, Scrivener crashes every time I try to sync. No error messages appear, the app just crashes while in the process of downloading the file list, before the progress bar ever appears.

iPhone XS Max.

Same for me !
iPhone XS Max !

For information, I’ve posted on this bug in a bit more detail in a different thread, including steps to recreate: [url]Scrivener iOS syncing via Dropbox continues to crash the app]

Same here. It also happens when I try to adjust anything in the Editor in Settings/Scrivener. iPhone XR.

Settings -> Scrivener -> … and then tapping…

Editor : The Settings app crashes
Background Colors : The Settings app crashes
Syncing & Sharing : The Settings app crashes

Ditto, and to which I would add that tapping Settings -> Scrivener -> Third Party also crashes Settings. Additionally, when entering Settings -> Scrivener -> Reset Scrivener, the scrolling becomes stuck.

iOS 13.0, iPhone 8

Apparently iOS 13.1 was released this morning. Definitely recommend installing that as soon as possible.


After IOS 13.1 update, still encountering this silent crash when trying to update my works.

Have unlinked and relinked Dropbox already. Have verified update works on iPad (non iOS 13).

Anything I can do to help diagnose this issue?
Thank you.

Syncing is crashing the App on iPadOs 13.1, too.
Is there a work around or recommendation how to proceed for now?
Can I use iCloud to sync?

See this post and the one after it for workarounds and troubleshooting suggestions:


Also having troubles opening my projects.

Got a new iPhone 11 yesterday with iOS 13. When I opened the Scrivener App, everything looked normal at first. Sync also went well without problems. But when I tried to open one of my projects, the error messages in the attached screenshot popped up.
It’s in German, I’m trying to re-translate:

“Invalid Project.
Project cannot be opened as it does not contain a valid folder structure file. Please make sure the project has been uploaded completely from another device and try syncing with Dropbox again.”

The same message is shown with every project I trie to open. The app does not crash though.

Uploaded to iOS13.1 this morning, still the same error.
Have not tried anything else so far.

Not sure is this helps, but I thought any info would be welcome.