Scrivener 2.9.42: Removing Carriage Returns (CR's) [Windows 3 Beta #218

Good day,

Could you please assist me in finding a solution to remove CR’s from an
ill-formatted paragraph pasted from an external document.

The following did not work form me.

The result were, the CR’s were not found.

I also tried using RegEx without success.

Please note I did accomplish this in version 1, therefore I believe the
functionality should still be available.

Could the replacement of CR’s be a standard function like the multiple

Thanks in advance.

I just tried finding CR or LF characters in Scrivener, or EOLs, and that doesn’t work.
I can find entire paragraphs, using ^.*$ , but search for \r or \n returns nothing. Bug.

My suggestion is to use an external text editor such as Notepad++, Atom, Sublime, jedit, or something similar, to edit those out. Show all characters, find out what’s there, and use the text editor’s find and replace (which will do regex if you tell it to) to get rid of them. Don’t use the notepad that comes with Windows; it doesn’t do regex.

Thanks for the input rwfranz , Like many others, I also use Notepad++ as my default text editor. The process is just cumbersome. I cannot wait for the final release of the Windows 3 version, it cannot arrive too soon.

If it’s a soft carriage return, i.e. not an end of paragraph, you can regex search for \x{2028}

I haven’t found a way to search for the end of paragraph, a.k.a. pilcrow mark :cry:

It seems to be only the Find dialogue having this problem.

Project Search will find ^$ for blank lines – but Project Replace seems to use the Ctl-f mechanism and it fails in the same way.