Scrivener 3.01 running under Crossover 21

A new version of Crossover was released today. My experiences with the upgrade on Fedora 34/Cinnamon Spin were thus:
I used the in-application process to upgrade from 20.0.4 to 21.0.0 on ‘Machine A’. Launching Scrivener failed after Crossover “spun” for at least a minute. Launching Aeon Timeline 2 also failed.
I then tried to remove 21 and revert to 20. I removed 21, but when I tried to reinstall 20, Fedora indicated that it couldn’t overwrite a newer version with an old one.

On a different box (‘B’)where Crossover had never been installed, I was able to install Scrivener and run it without issue. I deleted that ‘bottle’ and imported a Bottle Archive of Scrivener w/o issue.
I then used Timeshift to restore Fedora on ‘A’ from last night’s backup. I then proceeded to uninstall Crossover 20, and install 21. Once that was done, my existing installs of Scrivener 3 and Aeon Timeline 2 worked without issue. I didn’t have to reregister either Crossover, Scrivener, or Aeon Timeline – the licenses were just picked up from the config files.

Not only does Crossover 21 run Scrivener, but it also did so without renaming the ‘texttospeech’ folder or changing the SAPI library to ‘native’. Weirdly, however, Codeweavers has removed Scrivener altogether from its list of programs to install. You’ll need to install .net 4.7.2 to run Scrivener 3.x, of course.

If you are a Crossover user, I recommend uninstalling Crossover and installing the new version rather than doing an in-place upgrade.

Your mileage may vary. I haven’t tried the upgrade on any other distro.

I installed Crossover 21 on my Apple silicon M1 MacBook Air last night, using the updater that appeared on launch. Very quick and didn’t need to create new bottle, install .net of any version—texttospeech was already disabled—and Scrivener launched.

The window layout was odd and an alert came up saying Crossover couldn’t access an OpenGL or something, giving a whole list of alternatives to install which I couldn’t understand. I took a screenshot of it, dismissed the alert, and set about adjusting the layout.

Scrivener suddenly exited. I waited a moment, relaunched it and it came up with the layout back to normal, and no graphics alert.

I haven’t time to do more now, but I’ll pass the info on to CodeWeavers and update here in case anyone is interested.