Scrivener 3.1.2 compile to .mobi indents first paragraph

Hello,
I am a longtime Scrivener OSX user and have recently encountered a compile issue. My manuscript is in “novel” format where the first paragraph of each chapter is left justified (i.e., no indent). All subsequent paragraphs are, however, indented. When I compile to output a Kindle .MOBI file I find that the first paragraph of each chapter is indented, despite the fact that the originals are not. How can I rectify this problem?
Thank you in advance.
Ron
scrittore@comcast.net

I don’t know compile to .mobi from anything, so I am not your best bet for solution, but a couple of things it would be useful to know, for troubleshooting purposes, about your circumstance:

  1. When you say your novel is in “novel” format are you referring to the way paragraphs appear in the Scrivener editor? How have you achieved that look there? Using tabs or applying paragrah styles or? (Generally speaking, of course, the look of paragraphs is controllable and controlled by the compile format you are using, but this can be effected by things you can do in the editor, like using styles.)

Probably:

Slàinte mhòr.

Thank you both for your replies.
In regards to the second poster and “remove first line indents,” my assumption is that checking that feature will remove all first line indents, But I would like to, and have accomplished with earlier versions of Scrivener, protect the first paragraph of a chapter or section from indenting, while allowing indenting of all others that follow.

As for the question regarding Novel Format, I was referring to Scrivener’s Fiction format. And I am not using Styles.
Any further suggestions would be appreciated

If you look at the image again, there are five options, similar to what existed in version 2.

As lunk hints, the options listed are precisely aimed at achieving the effect you want.

It looks like you want to remove the first line indent from the first regular paragraph in a chapter. You should check the checkbox and see if that fixes the problem.

This would not explain where the indent is coming from in the first place, of course, it would just be using a compile setting to overrule it. To explain what is happening in the first place, we would need to look at the section layouts section of compile. My suspicion is that the formatting in the editor is not really in control of the format of your output – though there is a setting for this in that area. So, the indents you see in your paragraphs are not being inherited from your editor format, but are being created from scratch under the control of the section layouts area. Are you using a provided .mobi compile format or one you have tweaked?

Thank you., that’s exactly what I’ve been looking for … where in the program can I find those options?
As for the .MOBI compile, I am using the default setup, and I’ve made no changes.

I’m not sure what default settings means to you, but it might be better to start from the example “Ebook” compile format, in the left sidebar when you first open Compile. This is set up with a number of sensible defaults, and provides a good framework to start from if you wish to make the design your own. Starting from actual “Default” format would probably entail quite a lot of work to get back to where this one starts from (it is, with a few exceptions, meant to more closely emulate the “Original” preset in Scrivener 2—quite vanilla).

For one thing, “Ebook” already does indenting the way you would expect.

  1. File ▸ Compile…
  2. Double-click the Format you are using, in the left sidebar, to edit it.

The screenshot JoRo posted was from the Compile Format editor.

If you haven’t already, I’d recommend taking a look at our upgrade guide for Scrivener 2 users, here:
literatureandlatte.com/scri … date-guide

Katherine

Thank you so much, will do.

Here is a followup:
I’ve set up the text as depicted in your screenshot, A .mobi compiled file is read properly and as desired by the Kindle Previewer but not by the Kindle application or a Kindle device.

Perhaps the issue is with Amazon’s software or the Kindle generator in Scrivener?

I might add that a compiled pdf file is produced exactly as desired, and opens with the desired formatting in the Kindle application. Epub works as well on the appropriate device, so there appears to be an issue with the mobi generator.

If your settings are correct and display well in standard Kindle readers, but not the weirdly orphaned iOS “app” version—that would be this problem then.

Thank you, that appears to be the issue. The files load as desired in Kindle Previewer but not the Kindle reader app.

A followup in re the Kindle Previewer 3 export suggestion.
I have the latest version of the Kindle Previewer installed on a Mac Pro Tower running OSX 10.13.6. While the previewer reads the mobi file and displays exactly as the manuscript appears in Scrivener, it will not export a ,azk file. Using the file export or the command X approach results in nothing being exported. Unfortunately, what had appeared to be a viable approach to the original problem has turned out to be a dead end. I realize that it is an Amazon software issue, but I thought that a heads up was in order.

Last time I uploaded to Amazon, I had similar problems with their iOS app. So, I didn’t bother with creating a .mobi from Scrivener, or with the result of using Previewer. Instead, I created an ePub 3 using the “Optimize for Kindle Conversion” compile setting as described on p. 590, section 23.4, of the current Scrivener manual. I checked it in Previewer and then uploaded the ePub to Amazon. The result came out fine on all my device apps.

Even though L&L earmark this option for transmission to third parties, it seems that Amazon accepts it directly and their server’s conversion process (may) work better than anything I can put on my Mac at this time. It may be worth a try.

Thank you, I’ll give your method a try with my next Amazon upload.