Scrivener 3.1.4 - licence activation fails [SOLVED]

I’m running Scrivener 3.1.4 in trial mode on Ubuntu 18.04 (Wine 8.0.1) and it works fine. So fine that I’ve decided to buy the licence, and here comes the problem. I start the activation process, a pop up window opens, I insert my email and than I copy and paste from the email the activation key: when I paste it, I can’t see the separation dashes (there are spaces instead), and the activation fails. So I’ve tried to insert manually the key, but when I digit a dash I get a space, and the result is the same: it fails.
Anybody has an idea to fix it?
Thanks in advance for your help

Looking more closely, I can see the separation dashes (in a very, very light grey…). So, maybe the dashes might not be the problem

What error message do you get?

I get an “Activation Failed” error at the end of the process as “Activation Result”.

“There was a problem activating Scrivener. Please, try again in a moment, or restart your computer and ensure it is connected to the internet, then try again…”.
Well, I’m connected to the Internet and I’ve also restarted the computer, but I get always the same result

The most likely issue is that something about your Wine/Ubuntu configuration is interfering with the connection to the activation server.

What could it be? I’ve read in the forum that Wine comes with Mono installed and in a past version of Wine (4. something) uninstalling Mono fixed the problem.

I removed Mono from Wine as I read here and I’ve forced dotnet452.
The activation process was successful and Scrivener works (and compiles) just fine!