Scrivener (3.3.3) and grammarly

I have just updated to Scrivener (3.3.3): and suddenly my Grammarly will not work if a footnote or comment is added to the text. Without a footnote it works: with the footnote it works ONLY in the footnote and no longer in the main text. I have opened up the chapter I was working on last week in which there are footnote and with which Grammarly functioned. I am running the macOS 14 Sonoma.

I have already contacted Grammarly and they say that this is an issue with Scrivener 3.3.3 and that they have no workaround. HOWEVER, I downloaded an older version of Scrivener and the problem continues: thus, I expect is a problem generated between the new version of macOS and Scrivener.

Any help will be greatly appreciated. Grammarly says just not to use footnotes – LOL a book without footnotes – seriously, any help or suggestions…

Steve

I guess responsibility is down to which company says their product is compatible with the other company’s product. I’m unaware that Scrivener has made that commitment about Grammarly.

I am not concerned with “responsibility” but rather a workaround that would allow me get my work flow the way it was and thus get back to work. I gave details precisely because my guess is that it is something in Sonoma that is causing the issue. I am also interested to know if others have it. If they do, then we know were to start looking: if they don’t, then there may be something on my system that needs to be changed.

Again, any help would be appreciated…

1 Like

My experience is Grammarly ‘disappears’ if I let Scrivener fix a spelling error. Grammarly comes back if I click in the Synopsis area and back into the Editor.
Sort of irritating, but kinda non-intrusive on Grammarly’s part.
Grammarly is less respectful if i quit it in Scrivener, locking down my WIP for a true minute while it takes itself away like a sulking kid.

Seen people in other discussion groups saying similar things about other tools that go plundering the Scrivener file format after upgrades Sonoma.

Hello… before I reformat my HD and reload all my software: has anyone encountered this problem? If not, then it is time to reload my computer.
To be clear: Grammarly does not work with Scrivener 3.3.3 and MacOS 14 Sonoma if you have even one footnote. Without the footnote it works.

Please let me know if you have this issue or have heard of someone with this issue.

thanks in advance

Just curious … what problem are you hoping to fix by reformatting?

Grammarly worked with Scrivener before I updated to Scrivener 3.3.3 on MacOS 14 Sonoma. This means either: a) the problem is unique to the way Sonoma was installed on my computer – i have already reinstalled Scrivener and tried older versions of Scrivener; or b) the problem is with Sonoma. Either way, the only solution would be to go back to Venture. However, the only way to roll back the OS on a M1 computer is to reformat the HD and reload Ventura. If I cannot find a solution with Sonoma and Scrivener 3.3.3, then I need to reload Ventura.

I am in the middle of a large book project and relay (perhaps too much) on Grammarly to catch lots of small things that I may miss. Thus, for me it is an essential tool.

2 Likes

I did not update my iMac to Sonoma, and actually it’s too old to do an upgrade. But I did do a fully re-format and reinstall of the operating system (latest Ventura version) and recovery of data from the most recent Time Machine backup. Due to some sort of flaw on the SSD which , based on diagnostic work at the Apple Store, was repaired by the reformat.

That was a week ago. I’m still resetting permissions and making some of my apps which depend on some bits stored on the computer related to the OS. I don’t know version. Even doing a new Time Machine backup takes a few days as it does a very deep check of all the files. So budget a little bit of time to resolve niggling issues due to the reformat, unrelated to Scrivener, Grammerly, and your “large book project”.*

I never install *.0 versions of Apple’s updated macOS version, and plan to wait a few months as the only reason it looks I am missing anything, it’s those stupendous/beautiful/magnificent/[fill in your adjective] new desktop screen savers. :wink:

To me this does sound like an issue with Grammarly and Apple’s text system on Sonoma (Scrivener uses Apple’s text system). Some questions:

  1. When you say Grammarly stops working whenever a footnote or comment is added to the text, I assume you mean the sort of footnote and comment that appears in Scrivener’s inspector (as opposed to “inline” footnotes and annotations, where the footnote text appears inside the text itself rather than in the inspector) - is that correct?

  2. What happens if you start with some text containing no footnotes (so that Grammarly is working) and then add a link to the text (Edit > Add Link… and type in a URL)? Does Grammarly still work?

  3. If Grammarly still works with links, what about with a custom link? So, try going to Add Link again, but this time choose “No prefix” and for the URL type “test://something”. Does Grammarly still work after doing this?

  4. If the answer to either (2) or (3) is no - if Grammarly doens’t work when the text contains a link - what happens if you try the same in TextEdit? (Fire up TextEdit, check Grammarly works, then add a link to the text in TextEdit - does Grammarly still work? Try a custom link if only (4) was “no”.)

  5. If the answer to either (3) or (3) was no and the answer to (4) is yes, what happens when you choose Format > Wrap to Page in TextEdit containing text with a link. Does Grammarly still work then?

The reason I’m asking these questions is that the only thing special about a comment or footnote in Scrivener’s text is that it contains a custom link (which is used when you click on the comment or footnote so that Scrivener knows to open the inspector).

All the best,
Keith

Hello Keith,
thank you for taking the time and for all the suggestions: the answer to all is, no.
However, I have figured out the issue. Grammarly is no longer able to function in a text that has links to other pages and documents. Why? no idea, but there is no quick fix or workaround. Grammarly finally acknowledge that their developers know about this but need some time to analyze the cause of the issue.

For now I will make a short cut key that allows me to move between inline notes and footnotes quickly.

take care

Steve

1 Like

Ah, great, well I’m glad that Grammarly have figured the cause of the issue at least and are working on a fix. I thought it might turn out to be links, and the reason I asked you to check TextEdit is because if the problem occurs there then it rules out a specific problem with Scrivener (if TextEdit had worked, then there would probably be an extra factor in Scrivener that was involved).

Fingers crossed Grammarly are able to fix it fairly soon.

All the best,
Keith

Hello everyone or anyone who might want to know…

Grammarly has fixed the problem of using Grammarly in a Scrivener that has footnotes.

You just have to update your Grammarly desktop app : delete the current, download the new one.

take care

Steve

Thanks for the update!