Scrivener 3.3.6 crashes on Macbook Pro M3 Max

For years I never had a problem with Scrivener on my old macbook pro with Mojave most recently running 3.3.6. Recently bought a new Macbook pro with M3 chip running on Sonoma. With the new computer Scrivener crashes frequently while typing. Sometimes runs OK for an hour, or crashes within 5 minutes. I created a new project and pasted some but not all of the original project into the new one to keep working, but it still crashes the same as before. I haven’t been able to reproduce the event that causes it to crash because it occurs in the normal course of typing. File size is only 3 mb. Do you have a workaround? Maybe install an earlier version of Scrivener? I’m halfway through a novel and this is getting scary.

Definitely don’t install an older version of Scrivener, as there are several known crashes with older versions and Sonoma.

Maybe reset Scrivener’s Preferences file, as explained here:

Wouldn’t hurt to send us the crash report to look at. Please open a support ticket, here:

My Scrivener file was corrupted. I pasted some of the original files into a new document which continued to crash Scrivener. Then I made a new set of empty text files under Manuscript and pasted the text only into each one. Scrivener has not crashed since.
Thank you for your help. I’ve been using Scrivener for four years. It’s completely improved the way I write.

1 Like

Glad you are back in operation. Have you turned on the “auto save after X seconds of inactivity”? This will minimise loss on crash, I think. For me x=2 seconds. Also, watch for Sonoma updates…I’m still on macOS 13.6.1 on an older iMac and Macbook, so in no hurry to upgrade.

This is also a good time to check your backup settings, which you’ll find in the Settings → Backups pane.

1 Like

After 9 days Scrivener has started crashing again. How do I upload the crash report .ips file to you? Forum won’t allow it.
Scrivener 3.3.6 is running on Sonoma14.1.1 , on a new machine. I’m working on the same file mentioned above, where I copied and pasted text only into a new project. File size is 1.7 mb, text only with no graphics or photos. This is the first time since I started using Scrivener 4 years ago that it has crashed, and the file size of a project two years ago was over 500 mb. So maybe this is a problem with Sonoma?

Trying to reproduce the problem, I found that Scrivener crashes as the last word in a line wraps to a new line. I.E. as I type the end word in a line of text, the instant the character count exceeds the length of the line, instead of calling a carriage return, Scrivener quits. The workaround has been to change the size of the page after re-opening Scrivener so the text wraps differently. After that, Scrivener lets me work for an hour or more in the normal way, until it quits again for the same reason. I think it’s haunted. This morning I upgraded to Sonoma 14.1.2 which didn’t fix the problem. I’ll send you a crash report if you can tell me how to post a .ips file. Thanks for your help!

Best way to send a crash report is to open a support ticket, here:

I’ve discovered that while Scrivener crashes when composing in the main window, during the past 10 days, it hasn’t crashed when I use the Quick Reference window. This has been my workaround, otherwise Scrivener becomes impossible to use.

Have you opened a support ticket yet?

1 Like

This is happening to me for the same reason - I hit a line change and it crashes. I somehow fixed it in January 2024 when I was running Sonoma 14.2.1. Now it’s back with Sonoma 14.3.1. I’d love help with this! I sent a report to Scrivener.

Is this happening with only one project or with all?

Have you tried resetting your preferences?

Also try holding down the option key and choosing File > Close Project and Clear Interface Settings.

I can’t actually remember ever having Scrivener crash in the 17 years I’ve been using it… definitely not with the various iterations of v. 3 through all the Apple OS updates. Currently running Sonoma 14.4 on an M2Pro Mac Mini and an M1 MBA with no problems to date, none under 14.3.x.


Later: Is this an M3 Max problem? I hope you’ve sent the crash reports to Lit&Lat. Without those reports they can’t diagnose the problem if they can’t reproduce it.

1 Like